Jump to content

SUbishawnboy

Members
  • Content count

    5
  • Joined

  • Last visited

Everything posted by SUbishawnboy

  1. OK I am going to ask for help and see what happens? My 88 dl 2wd wagon w/ 200k plus miles is giving me clutch fits! A couple years ago I replaced a broken clutch cable, I thought at the time the parts house (Auto Zone or Oreillys/schmucks) had given me the wrong cable as the horseshoe clip to hold cable in bracket did not fit the new cable. I was able to make the cable work for awhile but now when i adjust the cable to where I can get car into reverse and shift, the adjustment does not hold. Lasts maybe an hour of driving and must be adjusted again?? I am determined to keep this car on the road as I feel it is just reaching its prime and I want to do my part to aid OPEC in world domination. My plan is to order a new correct cable- getting one from a dealer is too costly, trying to find a 2wd Subi in an OREGON u-pull it is like looking for UNICORNS OR HONEST POLITICIANS. Does anybody have advice? Once I replace the cable I am prepared to do the clutch and all hardware if not shifting happily? Thanks
  2. Ok, great advice I got the new cable from dealer. OEM cable is a bit shorter. New difficulty is .... I cannot recall exactly this attaches to the clutch fork and is there supposed to be a return spring? I noticed several of the photos ( on the net) on Just'ys and others. Mine is a 2wd 1988 are they not supposed to have a external return spring. Anybody have a pic of their clutch cable that you can post on here or in a reply. Please
  3. ok will check it out. No dealers opoen on weekends here. Thanks
  4. Oops I will try posting this better.....not used to this board stuff
  5. OK I am going to ask for help and see what happens? My 88 dl 2wd wagon w/ 200k plus miles is giving me clutch fits! A couple years ago I replaced a broken clutch cable, I thought at the time the parts house (Auto Zone or Oreillys/schmucks) had given me the wrong cable as the horseshoe clip to hold cable in bracket did not fit the new cable. I was able to make the cable work for awhile but now when i adjust the cable to where I can get car into reverse and shift, the adjustment does not hold. Lasts maybe an hour of driving and must be adjusted again?? I am determined to keep this car on the road as I feel it is just reaching its prime and I want to do my part to aid OPEC in world domination. My plan is to order a new correct cable- getting one from a dealer is too costly, trying to find a 2wd Subi in an OREGON u-pull it is like looking for UNICORNS OR HONEST POLITICIANS. Does anybody have advice? Once I replace the cable I am prepared to do the clutch and all hardware if not shifting happily? Thanks
×