Jump to content

swaggerwagonej22

Members
  • Content count

    15
  • Joined

  • Last visited

Community Reputation

2 Neutral

About swaggerwagonej22

  • Rank
    Member

Profile Information

  • Location
    Topeka kansas
  • Referral
    google
  • Biography
    im a mechanic by trade new to subarus, want to learn them so I bought an older high mileage legacy to restore and attempt to tune
  • Vehicles
    1994 Subaru Legacy wagon, 2001 BMW 330ci
  1. threw a code for tps (94 legacy ej22) replaced with new one. aligned with paint marks but still throwing the code, getting a sputter at WOT from a dead stop randomly, especially when not at full operating temp
  2. it doesn't always do it. could be a hest shield after trying to reuse them off an after market converter. that's a good lead. thanks. will be in touch
  3. it doesn't always do it. could be a hest shield after trying to reuse them off an after market converter. that's a good lead. thanks. will be in touch
  4. the throttle position sensor ended up clearing it up
  5. best way to describe would be like the tick of an exhaust manifold leak (which I confirmed it is not an exhaust leak)
  6. but it sounded like one specific thing. not like the rest of the little lifter ticks
  7. wouldn't really call it a knock, and it didnt get louder with rpm increase
  8. oh and I heard the noise most promenently under the oil pan through a sterhescope
  9. I'm going to get the Lucas out and flush and bleed the lifters and see if that helps. valve covers need resealed anyway. do you think it could be related to timing components? not sure if they have been done
  10. have a very light tick I narrowed down to the rods. it's super light not really a knock. is this at all common? running full synthetic 10 40 and lucus oil stabilizer....any ideas on how long I have before a rebuild? 120k on the clock
  11. swapped out my first cat with a MagnaFlow too
  12. I did plugs and wires when I bought it along with seafoam and an 3 part intake induction cleansing. got a code for tps and o2s, replaced both and everything mo'betta'. still seems to hesitate with a flucuating idle. going to clean up the iac tomorrow
  13. car sputters and hesitates at wide open throttle from a dead stop. after it gets going theres no problem
×