Jump to content

Search the Community

Showing results for tags '1979 brat'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 3 results

  1. Anyone know a place to order (or have made?) some wheel adapters for a 4 bolt '79 Brat?
  2. First time posting on here so I'll do my best to explain what's going on... As the title says my clutch pedal hinge is worn out and and rubbing up against the medal and when I push the clutch in it moves around a lot. Since it moves around it doesn't allow the clutch to disengage the tranny all the way and I can't shift smoothly and can barely get it into reverse without damaging something in the tranny. My question is if any of you have had this problem and know how to fix it, or if it's even fixable? I never noticed before but, I'm assuming it had some kind of rubber bushing in there to keep it from rubbing up against the medal, if so, that's obviously gone.. Thanks for any info you can provide!
  3. Hey to everyone at USMB, I recently just came across a '79 Subaru Brat that is in fairly good condition. I joined the board so could ask questions and show how my first Subaru and first fixer-upper goes. When I first saw this car I asked my grandmother "What the hell is that thing?" sitting in an old barn was this bad boy. Not even 23,000 miles on it!! some quick pre-start work and this bad boy started right up. Looking to get in registered and inspected in PA, will need a front-left turn signal assembly and a rear-left tail light, Any tips or advice is greatly appreciated!!!
×