Jump to content

Search the Community

Showing results for tags '1990 Legacy'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 6 results

  1. Brought my son's 1990 Legacy L Wagon to local mechanic because it's been running rough (hard starting, strange idling, stall at red light, etc.) The shop having trouble reading and deciphering all info given by computer because they don't work on vehicles this old often. They thought they narrowed down problem to Engine Temp Sensor, replaced but it didn't help. Now they're saying the ECU probably needs to be replaced. I think I need a second opinion. Long story, short: need a shop in Dallas that has experience with older Subaru's
  2. Hello everybody! Just a little background on my situation. I stumbled across a 1990 legacy for 600 bucks. Guy said he put in new tranny and had the engine out to replace seals and gaskets. Well 380 miles into my trip I stop and find I've lost 3 quarts of oil. Holy cow! Get home and see the oil pan and passenger side of engine has a thick coat of oil along withe a few drips of oIL on the underside of the timing belt cover. What are your thoughts on what might be my issue? M valve cover gaskets are clean and I can see that they are new.
  3. My 1990 legacy didnt idle for about a week so i replaced the MAFS, cleaned the throttle body, cleaned the air intake valve, replaced the PCV valve, replaced the PCV hose to the air intake. After all that she finally idles but its really rough it bounces from 0- about 1000 rpm is there any reason it is still idling rough? fuel filter? im not sure please help me out
  4. I have a 1990 subaru legacy manual Trans and I've been having quite the idling issue. I just replaced the MAFS and she still won't idle what so ever. I'm planning on cleaning my throttle body and replacing the gasket to see if that helps. I've already replaced the top end throttle body vacuum line and it didn't do anything to help. I need some wisdom due to this being my first import please help me out
  5. Hi all, new to the forum and in dire need of help. None of my power windows are operable and I can't find a wiring diagram. It's a 1990 Legacy wagon and I can't locate a power window fuse position. But wait, it gets better! The A/C is also inoperable. And....I have a broken right hand and the only other transportation I have are 5 speed Ford diesels. Any help is GREATLY appreciated
  6. Hey All, I am in need of some help from someone who knows their way around an older Subaru. I purchased a 1990 Subaru Legacy Wagon with only 86k miles on it from a single owner. The car is in great shape and I felt was an excellent buy. After putting a few thousand miles on it Ive noticed that the cars temperature seems to go a bit above the half way mark at times. Before say a month ago the temperature gauge lived between completely cold and mid way. I dont know if this is an indicator of a head gasket problem or if this could be the radiator. Ive heard the 2.2 4cyl 5-speed manual engines in that year dont have the head problems as much as the others do. Please help!!
×