Jump to content

Search the Community

Showing results for tags 'Automatic Seatbelt'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 1 result

  1. Hello! Recently the passenger side seatbelt in my '94 Legacy GT got stuck at the bend in the rear when retracting, and would not continue retracting when manually cranked (the crank was tight - wouldn't move). It was in this state for maybe a few days, after which it would try to move forward (moving a few inches), but it wouldn't go back. Eventually (a few more days), a big loop of the cable which should have pulled it back began spilling out into the car. The seatbelt is now loose on the track, so I'm pretty sure that the cable has either become detached, or has broken. Without tearing the entire car apart quite yet, does anyone know what kind of a job I'm in for here? Can the cable be replaced separately, or am I looking for a replacement track assembly? The motor seems fine, I've never had any problems with it up until now. Unfortunately, since the cable is broken/detached, I can't just crank it to the rear and leave it - I have to do something about it or I don't have a working seatbelt. Thanks in advance.
×