Jump to content

Search the Community

Showing results for tags 'Non-turbo'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 4 results

  1. My 2007 Outback with 236,000 miles pings. It pings a lot. Anything off idle it makes pinging noise. Cannot hear it with windows up. Tried Seafoam SS14 three times, Sunoco 94, octane booster. First bottle of Seafoam seemed to help but three days later it was back. New knock sensor. New timing belt.
  2. Greetings Scoob experts, I have developed a misfire and am struggling to get a handle on what the issue is. Here's some background: The misfire is only really apparent when the car is idling and you can hear/see the engine stumble slightly, not a a lot, bu it's there. Every now and then a check engine light will be thrown with a 0301 code. As the plugs and ignition leads were due a change, they got changed. No difference. The coil pack got changed: no difference. I tested the spark of that cylinder against the block when running: they all appeared consistent in timing and strength. I did a compression test: all the cylinders came up the same strength and healthy (the head gasket and all seal had all been recently changed). So now moving onto the fuel system, I figured that by swapping two injectors I could determine it would be the culprit if the code shifted from 0301 to 0303 (i swapped cylinder 1 and 3 over). The problem is that the issue is so weak that the CEL won't activate to determine it. Any advice? Thanks in advance.
  3. Would like to hear any experiences and thoughts on owning a 2000 ( or similiar) Subaru Impreza RX Manual Non-Turbo? Found one with about 223,200 kilometres on it for $5000, modded with wrx spoiler,rims, bridgestone tyres and twin tip muffler I know absolutely nothing so the more information, the better would like to learn about the engine, clutch, how reliable etc etc just tell me anything, just enthusiastic to absorb any information . Will be using this as a daily- highway driving- thoughts?
  4. Ok, so I think I'm in over my head, got an 07 impreza standard 2.5 with 5 speed. The motor and wiring harness were removed to install regular turbo motor. Bad investment? Problem I incountered right off the bat was the wiring harness, after getting all the info here is what I'm left to figure out. The new motor and wiring harness the car came with is from a 2004 base turbo impreza with an automatic trans and I need to put this into a 2007 Impreza non-turbo 5 speed. What will make this work? Do I need the harness out of a 07 turbo with standard trans to make this work/ or is this much more complicated than that?
×