Jump to content

Search the Community

Showing results for tags 'drivetrai'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 1 result

  1. OK I am going to ask for help and see what happens? My 88 dl 2wd wagon w/ 200k plus miles is giving me clutch fits! A couple years ago I replaced a broken clutch cable, I thought at the time the parts house (Auto Zone or Oreillys/schmucks) had given me the wrong cable as the horseshoe clip to hold cable in bracket did not fit the new cable. I was able to make the cable work for awhile but now when i adjust the cable to where I can get car into reverse and shift, the adjustment does not hold. Lasts maybe an hour of driving and must be adjusted again?? I am determined to keep this car on the road as I feel it is just reaching its prime and I want to do my part to aid OPEC in world domination. My plan is to order a new correct cable- getting one from a dealer is too costly, trying to find a 2wd Subi in an OREGON u-pull it is like looking for UNICORNS OR HONEST POLITICIANS. Does anybody have advice? Once I replace the cable I am prepared to do the clutch and all hardware if not shifting happily? Thanks
×