Jump to content

Search the Community

Showing results for tags 'floored'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 2 results

  1. Video of truck: Starts off stationary - at operating temp 0:10 - 0:30 then fwd 1st at 0:31 - 0:49 4wd lo first gear 0:50 into second last 10 seconds is 4wd lo 2nd gear, but going slow. Only speedo tach and thermometer work. I have oil pressure, and I'm not pushing 18v. I've done a new weber carb, fuel filters, plugs, plug wires, coil, and egr delete. Oil and filter are fresh These are the stock redline Weber subaru kit jets, with the short air filter, and a free flow (hollow cat, single muffler) exhaust Any ideas on what I should do next? This has been the problem my almost my entire time owning this thing, would be great to finally be able to floor it without killing it.
  2. Problem has been happening since I bought the car. Whenever I go to floor it the rpm's die down a few hundred, for about one whole second, and then shoot to redline. Problem has been happening on hitachi and weber. (this is the reason I swapped). New ignition coil, wires and plugs. Cap and rotor look good, but should I replace those? This is mostly a problem in gear, letting the clutch out without having rpms at like 6k will cause the car to die. Was thinking a fluid change is in order? Maybe seafoam? When the engine is not under load it almost always only dives down, and doesn't die. Also, how are nn a/c cars' alternators attached? Just with the one bolt? I took off my a/c and that's all I ran for a little bit (hour max) but it seems to get loose too quickly and has destroyed my water pump bearing. How are yours held on? Pics are welcome Thanks -CL
×