Jump to content
Ultimate Subaru Message Board

Search the Community

Showing results for tags 'valve body'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 1 result

  1. Hi Subi Fans, I have a 2005 Outback, 3.0R VDC 5AT w sport shift. Recently the CEL came on and produced code P0768, which has to do with the Shift Solenoid 'D' electrical. The solenoid is located on the control valve assembly, which is inside the transmission pan. The problem is intermittent, and I have been able to reset the code several times, but within a few miles the CEL comes on again. This last time while pulling a steady hill as it went to shift between 3 and 4. Until my next reset, it is stuck now in one of those gears. The sport shift would not work either. Of course, about half the lights on the dashboard are going wild, and cruise control is dead. After much investigation I am pretty sure no one is re-manufacturing or rebuilding these valve bodies, and no solenoids can be purchased separately. 1) Does anybody know where I can get a rebuilt valve body with tested solenoids? I have found a used transmission (131,000 miles) for $485, which includes shipping. 2) Is it a good idea to purchase a used transmission and then remove and reuse the valve body from it? Subaru still sells the valve body under part #31705AA4309L, and those run $750 to $935. It is a new part and has at least some warranty. This valve body fits a good number of 6 cylinder 5AT Subi models from 2005 to 2007. 3) Is my best bet going to be a new valve body? Last question. It is kind of a messy PITA job to get inside the tranny case just to look at the wiring and make sure things are plugged in, and replacing all the tranny fluid is not cheap. If I am opening it up I want to replace the valve body (or the D solenoid). 4) After replacement, does the car's computer need to be reset? Or can I just drive away? 5) If so, is that something I can do, or must the dealer (or my good independent garage) do it? If anyone can help, or has any resources, please let me know - I am OPEN TO IDEAS. The car is great otherwise, but has a salvage title and 208K, so we are getting leery of big expenditures to keep it going. I have had it for eight years. THANKS !!! Craig
×