Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
iauch

Overheating 93 loyale

Recommended Posts

i bought a 93 loyale a few weeks ago and it ran great around town. I took it out on the highway and it would overheat. It would only run hot when driving at high rpms. I replaced the thermostat and still has problem. I took it to a shop who found no problems with the coolant system and suggested that the tranny was not shifting into overdrive as when riding a 55mph it was running around 3250 rpms. After this, i drained the old trans. fluid and filled it with new fluid. After this the water pump began to leak fluid from the weep hole. I took it to a shop and had the waterpump replaced as well as the timing belts. It is now overheating when idling and after only 3 minutes of driving! I noticed when it was hot the upper radiator hose was hot but not full and there was a gurgling sound coming from the thermostat reservoir. I took out the thermostat and have to wait until tomorrow to get a new gasket from auto zone. I was going to try running it without the thermostat to see if it was maybe stuck closed. Am not sure where to turn next. the fan is coming on, there is no coolant leak, is it possible the brand new thermostat or water pump failed?

Share this post


Link to post
Share on other sites

Non OEM thermostats have a history of being crap. I would suggest going to your local Subaru parts desk and ordering a genuine T-stat. You can also boil your old thermostat to make sure it is working correctly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×