Jump to content
Ultimate Subaru Message Board
MRduke

Fan comes on immediately when cold, before cranking...

Recommended Posts

Hi all,

 

I know I had stumbled across some issue where this is the symptom in these forums, and alas I cannot find the dang thread again!

 

Why would the fan on the radiator go on right away when she's cold and not turned over?

 

Cheers...

Share this post


Link to post
Share on other sites

diagnostic check connectors plugged in when they are not supposed to be, or you have a code stored in the ECU, those are pretty typical.

state your year and model.

 

If you have an older BRAT, maybe it was hard wired in that way.

if you have Legacy and newer, than yeah, diagnostic d check connectors not supposed to be plugged in

Share this post


Link to post
Share on other sites

Ah haaaa.....yes, there is a purge solenoid code still in there. Will clear it after replacing and then I hope no cold fan! Thanks...

Share this post


Link to post
Share on other sites

92 wagon, should be under the drivers side of the dash by the column. There should be a pair of green connectors, and a pair of black connectors right next to each other, Neither should be plugged together.

The fans will cycle on, and off, and on again with the key on, engine off if the plugs are hooked together.

 

If the fans come on and stay on, then the coolant temp sensor could have failed. The computer defaults to running the fans continuously if the CTS fails. That would set a code though.

 

The A/C system can turn the fans on, make sure it's not set on a/c or defrost and see if that turns them off.

 

You could have a stuck fan relay, it's rare but possible.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×