Jump to content
Ultimate Subaru Message Board
iamvandemon

MY LIL' ROO (93' legacy wagon) !! w/ new pics !!

Recommended Posts

Here are a few picks of my Roo project:

 

12_IMG_1360.jpg

 

lol this site blocked the eff a gee in my account name.. lol super lame!

 

anyhow.. looks like i wont be posting after all.

Edited by iamvandemon

Share this post


Link to post
Share on other sites

still not workin. try goin to the FAQ and then scroll down to where you see general forum usage under the heading Board FAQ. once you click on the general forum usage. scroll down to the bottom to the heading Reading and posting messages. Then click on attachments and images.That should help you out.

Share this post


Link to post
Share on other sites

I had no prob getting into the pics, but I re-hosted anyway.

 

Anywaaaay, looks F'n awesome!

 

HIS pics:

 

11_IMG_1359.jpg

61_DS_M.jpg

31_FP_T.jpg

Edited by LegacyBrad

Share this post


Link to post
Share on other sites

I used:

SJR 3" lift kit

98' Legacy Outback Struts

92' - 94' dodge shadow 5X100 16"x6" rims

7.00-16 NDT Non-Directional Military Tires

 

I cut 16" out of the back bringing the bumper 17" closer to the rear tires.

 

No significant power change.

And thanks for posting my pics.. I had given up on it.

also I dont know what the "Any comparisons to a D/R?" question means.

Edited by iamvandemon

Share this post


Link to post
Share on other sites

Could I Ask about the Shortened Back... Was it for Off-Roadin' Purposses? ... to have a Better Angle?

The short Legacy Looks Nice! :)

To Post pics here very Easily, first Upload them to a Photo Host Site like Photobucket, then Open there the Pic and do a Right Click / Copy.

Then: To post the Pic here, just Right Click / Paste it in the Post.

Kind Regards.

Share this post


Link to post
Share on other sites

This car was gifted to me by an old farmer who had it sitting out in a field for a year or so cuz he had given up on it. It had 200k and wouldn’t run.

 

I got it running well again and sold it to an acquaintance. When I sold it to him, I told him to change the timing belt asap cuz it probably had the original one in it.

 

About two years and 40k miles later, he gave it back to me because the timing belt had broke and it needed a new exhaust. Actually the timing belt hadn’t broken... at first. The idlers bearings had run dry and bent and half tore its mounting bolt out of the block, and that had shredded the belt.

 

I figured that having been given the car twice was a sign that the abused rust bucket was meant to stay with me. I didn’t need another car though, so I decided to take it off road.

 

Now to answer your question, yes, I cut the back to give myself better clearance and increase my angle. I have a lot of other ideas and things I intend to do to it, just a matter of time and luck.

Share this post


Link to post
Share on other sites

I want to move the exhaust. I would have liked to run it over the axle type cross members, but the tank is in the way. Any one have any really good ideas of where to put it to get it away from the ground. I do run this thing on the road in winter so I do have to keep the exhaust.

Share this post


Link to post
Share on other sites

My trans wont go into Park. Any Ideas? The Shift linkage is in one peice still and I tried to move the lever on the side of the trans into park by hand but it wouldnt go. Is there an external senser that would keep it from shifting?

 

Has anyone had one of these '4EAT' auto trans apart? What internal parts would keep the gear select lever from moving into the Park position?

 

Thanks,

Van

Share this post


Link to post
Share on other sites

Oh wow! Thats pretty awesome

 

Like... a leggy hatch!

 

When you go offroading, take some vids! Id like to see that thing crawl around...

 

a unique modification like this requires a unique name...

 

You are driving the Subaru ..... (what will it be :brow: )

  • Like 1

Share this post


Link to post
Share on other sites

just pure crazyness...:clap::popcorn:

 

I too question the painting of the windows.

 

 

 

Did it start out as an LS or LSi?

Are you still running the stock EJ22? with from what I gather has 240Kish?

Share this post


Link to post
Share on other sites
I don't Know.. I guess because I could. It still passed safty inspection, so I'm happy.

 

You thinking it was a bad idea?

 

only issue i can see is it could create some huge blind spots

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×