Jump to content
Ultimate Subaru Message Board
TheLoyale

My '92 Landcruiser: Safariwagon-II

Recommended Posts

Tsk tsk... knock on wood*

 

Here in Oregon they do pull you over for it... We had to ziptie one onto the 240sx because it didnt have a front bumper so he had it displayed in the windshield, still got a fix-it ticket for it

 

I may just get one and put it on for show purposes :headbang:

Share this post


Link to post
Share on other sites

Been working on mine some... My rockers were out of adjustment... In a weird way though. The intake valves were actually very close, all were right around .008. The weird part was, the exhaust valves were ALSO around .008, I'm assuming whoever adjusted them last time set them ALL to .008, instead of the exhaust set to .014....... Anyhow, it's running MUCH better now. Also, stripped the running boards off, and put some 31's on it. The lift I ordered is waiting on front springs to come back into stock, so I won't actually have the kit until mid-June. I bought some 16x10 fake beadlock wheels off CL. And will likely go with 35's.... This thing is gonna be sweet! Here's an update pic.....

 

If you would rather I start my own thread I will, REALLY am not trying to threadjack here... Promise.....

 

spencer021.jpg

Edited by obk25xt

Share this post


Link to post
Share on other sites

Someone got lazy apparently lol. Did you also adjust them while the motor was pretty hot? I guess that is the correct way to do it, I burnt my hands enough when I did mine lol. 2 people makes it go easier though (Thanks dad!)

 

That thing looks better already! It is coming along nicely man. Needs something to break up all the white, wow! A black molding, mirrors or something lol.

 

You can make a thread if you'd like, you are also welcome to post updates here as well. I guess this is the Landcruiser thread ;)

Share this post


Link to post
Share on other sites

Ya, I read up on how to do it... After I had torn all into it (engine cold)... DOH! So I put it back together, and did it again the next day. Went for a drive, opened the hood, loosened up the hose clamps, throttle cable bracket, and valve cover bolts while it was still running. Then I shut it down and was workin within minutes. Finding the TDC mark was a beeeeotch even with help..... I still haven't actually set the timing with a light. I will do that soon... Also checked the MPG today... OUCH!!!! 11.5 mixed driving..... NO bueno! I gotta get my Loyale back on the road! I really like driving it though, super smooth and very comfortable. Needs tunes!

Share this post


Link to post
Share on other sites

I can't even see the timing window on the side, I haven't adjusted my timing by light either. Just by ear.. Only problem I have is, my disty is fully retarded and I get ping now and then. Why its at fully retarded escapes me, I dunno if someone put the disty back in, a tooth off or what?

 

The 3F-E is a slow revving motor, so these aren't the quickest off the line, shifting around 2500-3000rpm at most, with moderate acceleration. I was told not to rev these motors to hard, as they are an OHV Pushrod motor, but then again, so is the EA81. So I don't get it? Why wouldn't this motor handle higher RPMs well? Pushrod V8s can take higher rpms.

 

Anyway, these do ride nice, and ride even better with new heavier duty suspension. It will be firm and bouncy, but smooth :) I like driving the FJ80 a little more then the Subaru, but the MPG kinda sucks, if you know what I mean...! :burnout:

Share this post


Link to post
Share on other sites

My lift will be here on the 19th! And I also bought some used rear OME 860's off Craig's for $100, so I'll have some different rear options. The kit I ordered comes with 850's, which I'm told are 2" heavies, and I believe the 860's are 3" mediums? I dunno. Regardless, the Cruiser is coming along nicely and I'm diggin it!! My buddy dubbed it "The Storm Trooper" so I'm having some vinyls made for it too, I really like this rig.....

Share this post


Link to post
Share on other sites

Ya the kit is here! I'm really just waiting to take care of a couple financial obligations before I install it. Kind of a reward for doing the right thing sort of deal. Really, there's no reason I can't install it. But I'll feel better about it of I handle this small business first. It'll happen soon though!!!!!

Share this post


Link to post
Share on other sites

Nice Video... Any news on the Land Cruiser?

 

By the way, the other day I was walking in the street, doing some errands and I took my Cellphone to do a Phone call, then I saw coming on the Street, a Land Cruiser similar to yours, but with Factory Snorkel; so instead of doin' my Phone call, I shoot a Picture of it with my Cellphone's Camera...

 

The picture looks somehow, stretched due to the crappy cellphone's camera and the fast movement I did to catch that car on a picture... but here it Goes:

 

 

LandCruiserGSXwithFactorySnorkel.jpg

 

 

Kind Regards.

Share this post


Link to post
Share on other sites

Wow thats pretty cool, Factory snorkel is awesome!

 

I'm gonna order the axle seals next week so I can get this show on the road and get the truck, back on the road! :clap:

Share this post


Link to post
Share on other sites

Finally.... Got er lifted!!!!

 

These are 33's, I'm def gonna go with 35's on the 16" wheels, got plenty of room for them......

 

PICS.....

 

IMG_0868.jpg

 

IMG_0871.jpg

 

IMG_0869.jpg

 

IMG_0870.jpg

Share this post


Link to post
Share on other sites

Yeah 35x12.5 is the way to go on these. Wish I knew that before I bought my 33s lol.

 

Ordered the seals from CruiserOutfitters, should get them sometime next week I would guess. $129 shipped.

Share this post


Link to post
Share on other sites

Got the seal kit a few days ago. Looks like I'ma get messy this weekend! Gotta get some Moly grease, Gear Oil (Lucus) PB/Deep Creep, Steal a box of rags from work, Brake or Carb Cleaner, and some RTV incase.

 

Gonna take pictures as I go.

Share this post


Link to post
Share on other sites

Gonna be going up north on Oct. 6th, taking the rig on Northwoods OHV park for the 4wheelinwithfeelin event. Helps support March of Dimes.

 

Wish I had lockers!

Share this post


Link to post
Share on other sites

 

Wish I had lockers!

 

I think lockers are great, and also somewhat overrated on these things. I wish I had them too but with as heavy as they are, it takes a LOT to even get in a situation where one tire is off the ground enough to be "stuck". IF I get to a situation where I end up re-gearing, I'll probly put an auto locker in the rear, maybe..... I dunno..... So far I'm really liking the heck outta mine! I've got most of the necessary stuff to completely de-smog it, which I gueass will help with the idle and lower RPM smoothness. It really is a tank.... You can literally cruise the land in these things haha..... :-p

Share this post


Link to post
Share on other sites

I got new tires... Very happy with the fitment/driveability....

 

315/75/16 on 10" wheels....

 

I am really not trying to threadjack.... I just really like my cruiser! someday I will learn to take good pics haha....

post-31152-136027661679_thumb.jpg

post-31152-136027661686_thumb.jpg

Share this post


Link to post
Share on other sites
I just messed my self, watching this video...

 

Comin' along nicely tom!!

 

I know this is an older post, but I just had to respond.....since I live in Moab ;)

 

here are a few clips in chronological order. . .

 

 

 

 

and with my new (to me) UADM dual range 5MT

 

 

 

:banana:

 

that's enough teaser-ing for now, sorry for distraction, but try and make a trip down here and we'll go wheeling (you've chatted with my buddy with the black FJ80 on other forums)

 

Edited by superu

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×