Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
JonnieBlue

Audio Wiring

Recommended Posts

Does anybody know which wires are which in the stereo wiring harness in an 86 XT Coupe??

 

The harness has these wires:

 

NONE -- Ylw/Blk -- Ylw/Wte -- Grn -- Ylw ----- Rd/Grn -- Blk

ORNG -- GRAY ----- White -- NONE -- Ylw/Red -- Red -- Blue

 

The blue wire on the end has a 5A Fuse

 

If have exhausted my resources, so hopefully someone here has gone through this and can help.

 

There arent any adapters available (that i have found), and i dont have the time or know-how to re-wire everything. I cut the male wire plug off the old stereo, so i can connect the plug off the new stereo wire to wire with the old. I would REALLY like to have my new one in.. so any help greatly appreciated.

 

THanks

 

JB

Share this post


Link to post
Share on other sites

well.. i decided f*** it, im gonna re-wire it. but i was hoping that somone could tell me for sure which the "important", or non-speaker wires are which. So far, i think (based on a 'typical' diagram) that:

 

White = Hot at all times

Grn/White = Auto Antenna

Red = Lighting Switch

Blue / Yellow = Hot on Run & Acc.

 

On the new CD player, the book doesnt say anything bout a Lighting Switch, but it does say Constant Pwer Supply, Accessory/Switched Pwr, and Power antenna turn on. So what do i do with the Lighting Switch wire? Also, there were to black wires on the old harness, both next to eachother - are they both grounds? Also, cd player only has one ground wire, so is it okay to just pick one for a ground or what??

 

Thanks Again!

 

JB

Share this post


Link to post
Share on other sites

The lighting switch wire you don't need to use. Just wrap it with electrical tape and stuff it out of the way. The two black wires: I would try the larger of the two. I ran new wires from the battery on mine and I also ran new wiring for the speakers too. Hope this helps.

Share this post


Link to post
Share on other sites

the white wire is memory wire. the yellow is the light wire. the red is the the power i believe. the wires which share colors is the speaker wires. take a 9v battery and touch the pos. end of it to one of the wires, and ground the other side, this will help you find which speaker it goes to. it will make a sound like buzzing. the ground wire is black. i hope that helps.

Share this post


Link to post
Share on other sites

I was confused by the two blacks as well, i used a voltmeter to test which one was ground. The stock speaker wiring seems very strange, I could never figure out how to get them hooked to the right channels on the stereo. That and there were less speaker wires than speakers. Do they use common wires or something?

Share this post


Link to post
Share on other sites

You will have to run new wires for the speakers, since the speakers in the older Subarus share grounds, you will fry your stereo if you hook it up to the stock wiring, you will need to run new wires for the speakers. The only wires you need in the stock harness are the constant power wire and teh accessory power wire, and teh grounds. If in doubt, you can run your own ground wire to anything metal in teh car that is attached to the body of the car, as the body is the ground.

Share this post


Link to post
Share on other sites

Well.. i AM going the route of re-wiring.. so far so good, but what i need to know is (especially if youve done this before) how to wire the front (door) speakers. It looks like a giant PITA to feed through the thing were the wires are now (the black door to body tube-ish thing). Is there a better / easier way to do this?

 

Also, the wires have, i swear, no apparent color matching or anything. One side of the radio wire harness the wires are one color, the continuation on the other plug is a different color. The wires at the speaker are a different color than they are at the plug, and there arent any coresponding or opposite wires (like blue and blue/black etc), so re-wiring is definately the way to go, not to mention that stupid common connections crap :banghead: .

 

The back speakers i have already wired, so everything should be good to go except the front speakers - pending a board members reply or me finding a way :rolleyes: . So for now, i may just go with a two (back) speaker setup.

 

Im also swapping out the auto antenna with a regular old antenna. the auto is a real piece, and isnt workin well anyway so its gonna be gone. i dont forsee any problems with this swap, but then again i havent been having the best luck lately ;)

 

long story short, let me know if you got some advice on the front speakers.

 

TIA

JB

Share this post


Link to post
Share on other sites

The speaker connectors are located down by where the wires feed though that black tube which goes to the door. The connectors are pink. The left is white/blue on one side and Yellow / Blue w/ Red Stripe and the right is white/blue on one side and White / Blue w/ Black Stripe.

I just spliced there right after the connectors. That help?

Share this post


Link to post
Share on other sites

Well.. im still workin on the front speakers, but i just did my 'test' with the back ones and ... :headbang:

 

I cant tell you (though im sure many know) how good it felt to turn on the car, here the cd, then have the radio work too!! - Ive been without music for a long time..

 

Subynut: If i use the existing front speaker wires, wont it be all messed up still because of that common ground or whatever? If not, great! but i want to be sure im not F'n everything up.

 

BTW, the auto antenna removal went pretty well. Has anyone ever fixed theirs? Right now the antenna and plastic white inside thing with the ball stopper on the end is seperate from the motor, is fixing it fairly simple? I think ill tackle that next weekend.

 

Thanks for all your advice and support!1

 

JB

Share this post


Link to post
Share on other sites

The common ground happens a lot closer to the plug int he dash. At the point just before the wire goes into the doors is where you should splice in at. Take off the little kick covers in the footwells. You should see the above described connectors there. I would cut the factory wires, such so that you could still use the factory plug. Just incase you have to replace something in the future... Like a door or something.

 

Hope that helps!

 

Tex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×