Jump to content
Ultimate Subaru Message Board
AKghandi

Quiet Riot. My 87 GL-10

Recommended Posts

ok I ordered new radius rod bushings.

 

And from a local yard I'm getting a front caliper and parking cable,non A/C alt bracket setup, rear diff and snout bushing, and some blue front seats.

 

should have those in a day or so, then its into the shop for a bunch of work, she will never be the same.:headbang:

Share this post


Link to post
Share on other sites

PROGRESS!!

before

img0049qa.jpg

 

AFTER:headbang:

img0389zu.jpg

 

Not quite perfect, but i think that has to do with the age of the rest of the paint.

Share this post


Link to post
Share on other sites

AHAHAHHAA meme's.

 

the hood is going to stay black, but I am going to re paint it. I didn't have enough to paint the hood. I have a can left for the bumper and some touch up around the car.

Share this post


Link to post
Share on other sites

went wheeling with 2 Jeeps and a Range rover.

 

The car surprised the crap out of me:clap:

 

20130119121405.jpg

 

Working on a video for youtube now:D

Share this post


Link to post
Share on other sites

Finally got all the parts I've been waiting for.:rolleyes:

 

I got the non A/C alternator brackets, for that Leece Neville 140 amp alt and A/C delete,

drivers front caliper

extra rear diff with all the bushings,

Blue GL-10 front seats, a little dirty but in great shape,

got the rear headrests and carpet also, All matching,

and I got door panel tops for the front, and a window switch for the back.

 

After I clean everything up and put it in my interior will be 100% perfect:headbang:

 

the extra rear diff I have will be welded and after that I'm putting the car into the shop to do the clutch, front caliper,front C/V's, radius rod bushings,rear diff and some painting.

 

Stay tuned, will update with pics as soon as I get the chance.

Share this post


Link to post
Share on other sites

Been busy with my brothers wagon but,

I got my front seats put in, so much better than the WRX seats, my head doesn't touch the headliner anymore!

Share this post


Link to post
Share on other sites

Sweet video man, nothing too amazing at first glance, but this is a 26 year old subaru CAR.. It's pretty funny seeing people judge these machines and then putting their judgments to complete shame. Kept right up with the big boys:headbang:

 

I've definitely been watching your thread, I've got the same wagon, just base model. I'm a few big steps behind you, but am going to do pretty much everything you have done to yours, as well as a few personal touches of course.

Share this post


Link to post
Share on other sites

Thanks! yeah, my car was the only rig that wasn't having problems, they were spinning tires I was just driving along lol

 

I hope you can get your wagon up to speed, they are more than fun with a lift!

Share this post


Link to post
Share on other sites

I'm getting there, as always the only thing holding me back right now is money. I'll be ordering my BOSS 2 inch lift pretty soon here. Also got a line on some 14 in pugs. So we'll see, fun stuff could be happening soon!:clap:

Share this post


Link to post
Share on other sites

Hey how easy was that lift to install? ive got an 88 gl 10 that I have wanted to lift for a while, on the SJR lifts website it says that I need to extend my steering column? did you have to do anything like that?

Share this post


Link to post
Share on other sites

I got the BOSS lift from thebeastidrive its only $120 and is very well made.

with the sjr kit you have to drop the cross member an inch to help with the C/V angles with the boss kit there is no cross member drop.

same 2" lift just one is a little harder on your axles. On my car i have had no issues with axles because the turbos sit a little lower then the N/A cars.

 

install is easy, they are just spacers that go on top of the factory struts. can be done in a few hrs. the front is kinda difficult getting the struts back into the knuckles with the spacers but still very doable.

Share this post


Link to post
Share on other sites

What is the longevity of the Turbos on those?

 

I don't know much about that part of them.

 

I've always be pretty leery of Turbos.

SEARCH

Share this post


Link to post
Share on other sites

I finally got the clutch replaced, now all I have left to do is minor stuff I can do in my garage.

 

took me a grand total of 5 hrs over 2 days. all I did was unbolt the engine from the trans, unbolt the engine mounts, pulled the radiator and slid the motor forward enough to replace the clutch. the only things I had to unhook from the motor was the air intake, and the heater core lines.

 

Thank you Miles Fox for the pressure plate bolts through the starter hole trick. I couldn't get a clutch alignment tool in there. lol

 

Man are there a lot of leaks though. valve covers, oil pump, oil pan, turbo return lines, even the hill holder is leaking.

just that much more to do. oh well, I'll pull the motor and do a reseal on it in a few months.

 

 

I didn't take any pictures, because I was working in the cold and snow, sorry.

Share this post


Link to post
Share on other sites

Finally got around to replacing my radius rod bushings. WHAT A DIFFERENCE. its not so squirrelly in FWD when I floor it and the front end just feels so much tighter.

 

img0390zz.jpg

 

img0391qt.jpg

 

img0392pz.jpg

 

 

Last thing I need to do is install that Leece Neville 140 amp semi alternator. But I think that can wait. for now i need to put all my hard work to use and get a job :P

Share this post


Link to post
Share on other sites

well, all the hard launches and abuse finally caught up with me... the trans went ka-put about a month ago. It was weird, I drove through  puddle, and when I got to the other side, I pulled it out of gear and now the shifter is locked up. wont go into any gears, luckily I have another car to drive..just another thing I need to fix, not surprising though that trans had close to 400k on it.

Share this post


Link to post
Share on other sites

i read this whole entire thread before i went to bed last night.  made me dream about my old 1988 GL-10.  Wish i still had her.  Hope to see you having your car up and going again.

Edited by soobie_newbie67

Share this post


Link to post
Share on other sites

FINALLY!!!!! I got the trans replaced, its soooo good to drive my car again.

 

fzp.jpg

 

New trans!

5irb.jpg

 

 

 

And heres the victim.

lgg9.jpg

 

 

 

I also made a video which will be uploaded soon 

Share this post


Link to post
Share on other sites

made some more progress on the car today.

 

I've been wondering why my MPG's were not what they used to be... and I figured that out this morning. while checking an amplifier to see if it worked i noticed the fuel filter leaking like a siv... threw a new all metal one on and all is good now.

 

and while I was in there I replaced the battery, alternator, battery terminals, and cleaned up the wires. car runs really really smooth now. I'm quite happy.

 

 

Once the weather gets better I'm going to wash and paint the car, touch up the rust areas and re-black the trim. should be pretty spiffy.

 

 i may or may not put the exhaust back on. still not decided on that one.

 

 

and of course the plague of the lifted subaru has struck and the pass side inner c/v boot tore.. I've got another axle to put in and I have another inner boot.. not sure which I'll do yet,

 

 

 

 

I HAVE TOO MANY SUBARUS :P .. I currently have 4... all lined up on the street. the two lifted rigs, the red parts car and a recently acquired $150 90 loyale.

Share this post


Link to post
Share on other sites
Got around to touching up the paint on my car, painted the front bumper and painted all the trim around the windows.

also finally put the trim piece that goes under the headlights and grill back on.

and to top it off I put a honey comb grill on it.

 

Seafoam works amazingly well for bringing rubber trim back to a shine. it soaks in and lasts a long time.

 

 

Still need to figure out what I'm going to do with the hood, I've painted it 3 times, and it always gets a stripe patern.

Going to try some gloss instead of flat and see if that helps. i might even clear it.

 

 

 


0rk9.jpg

whl.JPG

xs9r.jpg

 

Edited by AKghandi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×