Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
jj421

Cruise Control Installation

Recommended Posts

I'm going to start off by saying I don't have a single clue about how the cruise control system is set up in an EA82. I've never even thought about installing a cruise control in my Loyale before, but recently I thought it would kind of a neat addition.

 

Yesterday, I picked up some parts for the cruise control system from Skylar. I guess it was a dealer installed kit, as he said the controls were under the rear defrost button. This is what I picked up:

 

P1130262.jpg

P1130263.jpg

P1130264.jpg

P1130265.jpg

 

It looks like I have the "brain" (wire is cut), throttle actuator (he also gave me the little chain thing, but I don't know exactly where that goes), and the black sphere thing. Which I guess is 80% of what I need. I believe I need the brake switch, clutch switch, and the switches to actually turn on/off the cruise control.

 

So basically what I need to know is:

 

-What else I need

-Where these things go

-How they're hooked up

-Where the vacuum/electrical lines go to, and how they get there

 

I've searched and searched, but can't find any diagrams or anything. If someone could post a diagram, or pictures of their cruise control setup in their car, that'd be amazing. I'll probably head to the Pick-N-Pull this weekend to see about getting the controls for the cruise control, as well as the brake/clutch switches. But if anyone has these parts that they don't need/want, speak up. :D So yeah, any help would be greatly appreciated. :)

Share this post


Link to post
Share on other sites

Sweet, that'd be great. I don't think dealer installed cruise control has controls on the wheel, but I don't think it's difficult to put that in. But is the setup different between factory and dealer, since the dealer setup is independent?

Share this post


Link to post
Share on other sites
Sweet, that'd be great. I don't think dealer installed cruise control has controls on the wheel, but I don't think it's difficult to put that in. But is the setup different between factory and dealer, since the dealer setup is independent?

:banghead: Wayyy different!! Good luck! May the subie gods look down on you with kindness!:o

Share this post


Link to post
Share on other sites
:banghead: Wayyy different!! Good luck! May the subie gods look down on you with kindness!:o

 

That's what I was afraid of. Dang, well that sucks then, haha.

Share this post


Link to post
Share on other sites
That's what I was afraid of. Dang, well that sucks then, haha.

If you got lucky:brow:= AGAIN May the Subie gods look down upon you- You might find a unmolested car at the yard an get lucky:) The Japan cars were pretty good about the wire harness having everything

built-in from the factory so if you want to add fac. stuff you just have to go digging for the plugs so if you find 1 with everything you just have to remember where it"s at!! As 4 me :drunk:

Share this post


Link to post
Share on other sites

If I manage to make a little money (CHRISTMAS I HATE YOU) I was hoping to head down to a pick n pull in south jersey. There's a red wagon there (The only GL in this state as a matter of fact in a junkyard) with cruise in it. Didn't get to see whether it was factory or dealer. Hoping to go snag it one of these days.

Share this post


Link to post
Share on other sites

I think I have a good chance of finding a Soob with cruise at a junkyard. I've never been at a Pick-N-Pull that doesn't have one. Last Saturday, 1 of 5 of the EA82s there had cruise. The time before that, ~5 of 10. The time before that, ~3 of 5. So I'd say a good 30%-40% of the EA82s in the junkyards here have cruise.

 

I hate how the dealer and factory installations are so different. It limits the number of people that can help me and the number of Soobs I can pull parts off. Oh well. Hopefully I'll get this set up soon. I don't like cruise control because I take it as a "luxury," but I think it'd be neat to have and I'll use it from time to time. But yeah. Saturday I don't work, so I'll head up there and see what I can find.

 

In the meantime, I'm still looking for diagrams/pictures. I can take a look at the system from the car I pull it off of, but if I don't know where anything goes, having the parts won't help much. :-p

Share this post


Link to post
Share on other sites

Yes, the dealer and factory cruise systems are quite different. Most post-'86 cars will have the same system with only a few cosmetic changes (mostly the steering wheel or button styles). Still you'd want to be pretty close to whatever year the target car is. Otherwise, it's really easy to pull the factory cruise from a car that has it (speaking only for EA82s):

 

FIRST THINGS FIRST:

Make sure you have a cruise control capable wiring harness in your target car! Not all cars will have all of the plugs just waiting for a cruise system to be installed, so make sure that you, in fact, do have the applicable connectors before you start.

 

*The cruise control main switch is underneath the rear defrost button. You'll need the entire rear defrost switch/cruise switch unit (they're one assembly, you can't just take the cruise switch part of it).

*The cruise actuator on non-XT models is actually under the steering wheel connected directly to the accelerator pedal linkage. Unclip the actuator linkage from the pedal, undo the one bolt to free the actuator bracket from the pedal assembly, and there's your actuator. You'll want to pull the vacuum line out with it; there's a coupler under the hood you can disconnect and then just pull it through.

*You'll need the brake switches (set of two switches into one 4-pin connector) and the clutch switch (if applicable). They're fairly easy to remove, on the pedal assembly near where you removed the actuator.

*The ACCEL/RESUME switch assembly on the steering wheel. Pretty much just take the steering wheel pad off and there ya go. There was more than one steering wheel style, though, so you may have to look around to find one that matches yours. Or, take the whole steering wheel if you like the other style better.

*The cruise control circuit unit lives above the glove box. So, remove the glove box, and there should be a silver box up there on the underside of the dashboard. Simply remove the screws and disconnect the harness. It should say "CRUISE" somewhere on it; if not, you may have the trip computer circuit unit (if the car is so equipped), in which case, pull out the other little circuit box under the dash and it should be the correct one. Just make sure you look before you leave.

*Finally, the vacuum pump assembly. It's on the RH strut tower. You may need to remove the air cleaner to get to all of the bolts. Also, you should keep the bolts you removed in order to reinstall it, as they're odd lengths. When removing the vacuum pump, make sure to take all of the vacuum hose along with it (including the very long hose that goes from the pump to the actuator).

 

Reverse the process to install it in your target car, and you're pretty much good to go.

 

As for installing factory cruise in a car without a corresponding wiring harness: it's possible, but there would be lots of custom wiring, including splicing into some of the gauge sensors (most notably, the speedometer's speed signal generator) and running power and signal wires from the circuit unit under the dash to the vacuum pump in the engine compartment. It'd arguably be easier to pull the wiring harness (the 'F'ront and 'I'nstrument harnesses) and do it correctly instead. Also, you could use this opportunity to swap in an MPFI engine, or to install the digital display and/or trip computer as well.

Share this post


Link to post
Share on other sites

Since you live close, I could give you a hand as I just removed the same setup from my coupe. It was actually really easy once you know where everything goes.

Share this post


Link to post
Share on other sites
Since you live close, I could give you a hand as I just removed the same setup from my coupe. It was actually really easy once you know where everything goes.

:clap: Lookie there jj421:) You have it all-The Parts+ a Hand:D!! You must have Prayed to the Subie God"s:cool:

Share this post


Link to post
Share on other sites
Yes, the dealer and factory cruise systems are quite different. Most post-'86 cars will have the same system with only a few cosmetic changes (mostly the steering wheel or button styles). Still you'd want to be pretty close to whatever year the target car is. Otherwise, it's really easy to pull the factory cruise from a car that has it (speaking only for EA82s):

 

FIRST THINGS FIRST:

Make sure you have a cruise control capable wiring harness in your target car! Not all cars will have all of the plugs just waiting for a cruise system to be installed, so make sure that you, in fact, do have the applicable connectors before you start.

 

*The cruise control main switch is underneath the rear defrost button. You'll need the entire rear defrost switch/cruise switch unit (they're one assembly, you can't just take the cruise switch part of it).

*The cruise actuator on non-XT models is actually under the steering wheel connected directly to the accelerator pedal linkage. Unclip the actuator linkage from the pedal, undo the one bolt to free the actuator bracket from the pedal assembly, and there's your actuator. You'll want to pull the vacuum line out with it; there's a coupler under the hood you can disconnect and then just pull it through.

*You'll need the brake switches (set of two switches into one 4-pin connector) and the clutch switch (if applicable). They're fairly easy to remove, on the pedal assembly near where you removed the actuator.

*The ACCEL/RESUME switch assembly on the steering wheel. Pretty much just take the steering wheel pad off and there ya go. There was more than one steering wheel style, though, so you may have to look around to find one that matches yours. Or, take the whole steering wheel if you like the other style better.

*The cruise control circuit unit lives above the glove box. So, remove the glove box, and there should be a silver box up there on the underside of the dashboard. Simply remove the screws and disconnect the harness. It should say "CRUISE" somewhere on it; if not, you may have the trip computer circuit unit (if the car is so equipped), in which case, pull out the other little circuit box under the dash and it should be the correct one. Just make sure you look before you leave.

*Finally, the vacuum pump assembly. It's on the RH strut tower. You may need to remove the air cleaner to get to all of the bolts. Also, you should keep the bolts you removed in order to reinstall it, as they're odd lengths. When removing the vacuum pump, make sure to take all of the vacuum hose along with it (including the very long hose that goes from the pump to the actuator).

 

Reverse the process to install it in your target car, and you're pretty much good to go.

 

As for installing factory cruise in a car without a corresponding wiring harness: it's possible, but there would be lots of custom wiring, including splicing into some of the gauge sensors (most notably, the speedometer's speed signal generator) and running power and signal wires from the circuit unit under the dash to the vacuum pump in the engine compartment. It'd arguably be easier to pull the wiring harness (the 'F'ront and 'I'nstrument harnesses) and do it correctly instead. Also, you could use this opportunity to swap in an MPFI engine, or to install the digital display and/or trip computer as well.

 

Well, thanks, mdcc2010, for making sound complicated and near impossible to do. :dead: Haha, but thanks for the info. However, you're saying factory cruise, but I'm looking to install dealer cruise. I've heard factory cruise installation requires modifying the wiring, but dealer cruise does not.

 

I'll probably be unlucky enough to not be able to install cruise control in my car for some reason, haha. Oh well. I'll print out your tips and bring it to the junkyard tomorrow.

 

Since you live close, I could give you a hand as I just removed the same setup from my coupe. It was actually really easy once you know where everything goes.

 

I really wouldn't mind having you help me with this, if you can. It seems pretty simple, but I'd still appreciate the help. You should come to the Pick-N-Pull with me tomorrow if you need parts for your car. I'm gonna go up to Arlington since they have quite a few Soobs, and might hit Lynnwood on the way back if I don't find anything. Since you have pulled the setup out of your coupe, you could show me what to pull out on a junkyard car.

 

:clap: Lookie there jj421:) You have it all-The Parts+ a Hand:D!! You must have Prayed to the Subie God"s:cool:

 

Hahaha, man, you do love your emoticons. :D But yes, the Subie gods must be looking down on me this week. :-p

Share this post


Link to post
Share on other sites

So just as an update, it looks like I won't be able to add cruise control. Went to both the Arlington and Lynnwood Pick-N-Pull, but only three cars had cruise control. One cruise system was destroyed (the wiring and stuff was cut and missing) and another was factory installed (I don't want to deal with that). I tried to pull the cruise off of the third one. I managed to get the button under the rear defog switch, the buttons on the steering wheel, the vacuum lines, the vacuum pump, and some wiring. I bought the stuff, $60, and then when I got to my car, I decided to put on the steering wheel for the ride home. Realized I can't even plug the steering wheel in. Every single Loyale/DL/GL in the junkyard had a 3-prong connection for the horn, but mine only has a one prong. Needless to say, I returned everything and decided I'm not going to install cruise control. If I can't even install a new horn, what makes me think I have the connections for anything else?

 

Oh well. Got two coolant temp sensors, a fan switch, and some spark plug wires. So it's worth the trip, I'd say, since the coolant temp sensor are the biggest problem with my car right now.

Share this post


Link to post
Share on other sites
So just as an update, it looks like I won't be able to add cruise control. Went to both the Arlington and Lynnwood Pick-N-Pull, but only three cars had cruise control. One cruise system was destroyed (the wiring and stuff was cut and missing) and another was factory installed (I don't want to deal with that). I tried to pull the cruise off of the third one. I managed to get the button under the rear defog switch, the buttons on the steering wheel, the vacuum lines, the vacuum pump, and some wiring. I bought the stuff, $60, and then when I got to my car, I decided to put on the steering wheel for the ride home. Realized I can't even plug the steering wheel in. Every single Loyale/DL/GL in the junkyard had a 3-prong connection for the horn, but mine only has a one prong. Needless to say, I returned everything and decided I'm not going to install cruise control. If I can't even install a new horn, what makes me think I have the connections for anything else?

 

Oh well. Got two coolant temp sensors, a fan switch, and some spark plug wires. So it's worth the trip, I'd say, since the coolant temp sensor are the biggest problem with my car right now.

Bummer...:( Well sometimes the Subie Gods won"t let you do stuff...they might think it"s fine the way it is...Each Subie has it"s own mission:D

Share this post


Link to post
Share on other sites

My main goal with this car is to keep it as stock as possible, and any modifications should be reversible. So I guess not being able to install cruise helps towards following this goal. Still would've been a neat feature to have though. Although I feel like I wouldn't use it enough to make it worth it. From what I've heard, having a 5 speed in a hilly area makes cruise control virtually useless.

Share this post


Link to post
Share on other sites
My main goal with this car is to keep it as stock as possible, and any modifications should be reversible. So I guess not being able to install cruise helps towards following this goal. Still would've been a neat feature to have though. Although I feel like I wouldn't use it enough to make it worth it. From what I've heard, having a 5 speed in a hilly area makes cruise control virtually useless.

YAA Think!!! Sorry for the sarcasim.... I"m used to hills/mtns! cruise cont. is useless unless you live in Nebraska or Kansas flatlands!!!

Share this post


Link to post
Share on other sites

Haha, well, with an automatic transmission, it's fine. And I guess extra power is helpful too.

 

I remember years ago before I started driving, I wondered if manual transmissions even could have cruise, haha.

Share this post


Link to post
Share on other sites
After Jury duty this week, I chanced to have time to pick up a water pump belt pulley after mine destroyed itself. <the pump bearing failed in a most dramatic way> This is not something that O'Reilly Auto Parts stocks on a regular basis.

 

UPAP usually has about five to ten 1985-94 Subarus in their yard, and I found those were all gone with only two "new participants" remaining: a 198x beat-to-hell BRAT (it was abused) and a near unmolested 1989 DL wagon SFI, sans front bumper. 120,000 miles. 5-Speed Manual 4x4 on the stick. Roll up windows.   I grabbed the engine fuses and the water pump pulley.

 

I'm sure this has everything to do with the cost of cars per ton coming back up from zero.

 

Interesting thing was that it had cruise control where my "automatic mirrors control panel is on the dash for my loyale.

 

Link to the car search while it's still posted.



 

I suspect I'll go back and get the fuel pump, radiator, and maybe the 4 axles for my project(s), but I'd be willing to get the cruise control for someone else.

 

<the cruise control module on the front dash, not the wiring harness, computer, aux crap all over the engine, wheel sensors etc..>

 

pic:

post-63273-0-43988700-1497630865_thumb.jpg

Edited by jsyme

Share this post


Link to post
Share on other sites

Yeah the kit for the DLs mounted them there, since the DL had it's own steering wheel not compatible with the wheel mounted buttons.

 

From what I recall though, the power mirror switch is on the other side of the dash.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×