Jump to content
Ultimate Subaru Message Board
turbosubarubrat

1983 ea81t gl wagon build

Recommended Posts

Wow you have been busy. That is going to be sweet ride when your done.

yah its going to be a nice ride when done, somebodies going to love it when im done building it ;). once im done putting it together, getting all the stuff done at dmv, going through deq, getting tags, and driving the thing abit its going up for sale if only it were a 2 door sedan or brat :(. the only thing it will really need when i let it go will be a paint job, the rear quarter pannel have a little bondo, and the passenger fender bent back to shape at the bottom or get another one.

Share this post


Link to post
Share on other sites

went to the junkyard today and got a factory radio with both connector sides plus the shifter cover and radio cover combined for $25 with 2 plastic pieces :) and i got the radio installed and it works great i just had to wire it in. also i got the rest off the off the mounts bolted on for the motor/tranny plus i got the streering wheel hopefully aimed right :Flame:

Share this post


Link to post
Share on other sites

2/10/13

86 xt-6 turbo wiring distribuator harness

64455_254706497997829_2034092090_n.jpg

379337_254706687997810_183721187_n.jpg

17679_254706737997805_2048389083_n.jpg2/11/13

285243_254706814664464_441065701_n.jpg66713_254706861331126_1237347746_n.jpg527985_254706897997789_1251582244_n.jpg17694_254706937997785_1780788822_n.jpg60723_254706981331114_280231738_n.jpg2/12/13

switched wheels and tires. for two reasons the tires where old and weathered and i want the rims

17015_254707287997750_1027384422_n.jpgalso did a seat swap. had these in my brat but blue looks better with blue instead of tan and blue.

527998_254707384664407_140515605_n.jpg

Share this post


Link to post
Share on other sites

went to two junkyards today and i got a spare rear defroster switch, the hard plastic piece that is by the seat belt for the drivers door, and turbo lines. for the brat got a new sigaret lighter(well old but has never been used so is shiny even where the sigaret is put to light), factory radio, spare third eye :D , and a brush guard B) . also got a subaru embelm off a 4 door sedan that has the hole for the key to go through thought i can sell. probably going back tomarrow to get a chrome bumper for the brat too.

Share this post


Link to post
Share on other sites

2/17/13

stripped down the distribuator wiring harness and cut it down to fit

64141_259982057470273_1636243611_n.jpg

387527_259982234136922_1658824977_n.jpg

541526_259982294136916_2038767350_n.jpg529944_259982360803576_1233394776_n.jpg533103_259982407470238_483382710_n.jpg557928_259982447470234_1980585253_n.jpg581868_259982504136895_378118807_n.jpg

2/24/13

got a plastic piece and turbo lines. also made a turbo line482326_259982610803551_974394119_n.jpg

421795_259982720803540_744138034_n.jpg

553158_259982800803532_121740799_n.jpg182458_259982894136856_1696300209_n.jpg

313378_259982937470185_1367376344_n.jpg

Edited by turbosubarubrat

Share this post


Link to post
Share on other sites

3/16/13

420384_270400776428401_1875693848_n.jpg5346_270400879761724_1366289493_n.jpg3/17/13

541112_270401543094991_352101398_n.jpg292272_270401723094973_2092340120_n.jpg6445_270401806428298_872627176_n.jpg482099_270401929761619_1762307780_n.jpg579135_270402009761611_285705026_n.jpg

3/24/13 where is the u shaped hose supposed to go? i do not think  it is even the right hose but it came with it on it. is it supposed to go to onto the intake monifold where the thermostat is?579995_270402653094880_1637233872_n.jpg

1684_270402699761542_1045656662_n.jpg

Share this post


Link to post
Share on other sites

Did you install the copper crush washers on the bolts for the water inlets for the turbo? If not they will leak when you do get coolant to it.

Share this post


Link to post
Share on other sites

Updates... :popcorn:

sometime soon since im out of school next wednesday :banana: hope to figure this hose mess up soon and get the radiator support put on my brat. i went to a wagon for sale identical to this one awhile ago and figured some stuff out.

Share this post


Link to post
Share on other sites

sometime soon since im out of school next wednesday :banana: hope to figure this hose mess up soon and get the radiator support put on my brat. i went to a wagon for sale identical to this one awhile ago and figured some stuff out.

irorny at its finest im getting her a twin today and its the same one i looked at to figure to try to figure out the hoses :D pics are coming later

Share this post


Link to post
Share on other sites

Shes back together and all the hoses are right now i made a y connector to tap into the coolant inlet line for the heater core to go to the turbo. The hard line for the coolant inlet i cut off part of it and welded back on to point toward the drivers side of the engine bay. I also adjusted the valve clearance again since the engine still felt to tight. Replaced the fuel pump with one off a ford f-250. Just when i thought she was going to fire up the starter went caput on me even though its a napa reman with stickers still on it from the junkyard. I think a gear or something broke because the starter turns really freely both ways while the two spare manual transmission starters i have only trun one way plus i tested it and nothing. So another trip to the junk yard is in order for tomorrow.

Share this post


Link to post
Share on other sites

Got her running but idling really high(im guessing like 4000rpm since i dont have a gauge cluster in at the moment), so im a tooth off or some thing on the timing. It turned out why it wasn't running is that it wasn't getting enough compression. It had 50-70psi in each cylinder, so i unpluged the spark plugs wires and started tightening and loosing the clearances on each cylinder until i had about 150psi just by going by what the compession tester said since the filler gauge has been screwing me over with this.

Share this post


Link to post
Share on other sites

She was running ok and i fixed the exaust leak, but im going to put on another cat. because it still leaked so i quess its rusted in the center that is a main reason why it sounds like crap. Im going to put  the new one where it orignally was just below the turbo by the fire wall. I finally traced the coolant leak which turned out to be the weep hole for the water pump after taking off the alternator and pulling the ac condessor with bracket :rolleyes:. Just got the new pump tonight so hopefully tommorrow i will get to drive out of the green house and wash all the dust off of her. The brakes need blead some more before that happens but luckily i didn't need to replace the master cylinder because it turned out just to be a clogged bleader valve on the drivers side rear :). I have a cluster in thats non turbo and it idles about right but dies  hope to solve that too.

Share this post


Link to post
Share on other sites

Back when i put the f-250 fuel pump on

1654058_415606821907795_939449533_n.jpg

1499576_415607415241069_1004925982_n.jpg

Turbo plumbed to run oil and coolant a couple months ago

1621929_415607088574435_1675724382_n.jpg

1622258_415607201907757_904756578_n.jpg1782141_415607268574417_1487481737_n.jpg

water pump was leaking from weep hole and replaced it a couple months ago with a new one from knects plus some new hoses

1926714_415608358574308_2113186341_n.jpg1010801_415608625240948_500240503_n.jpg

1964779_415609671907510_967810201_n.jpg

shows how long it sat (taken a couple months ago)1962713_415610758574068_1527310011_n.jpg

1797522_415611081907369_710265588_n.jpgRadiator was leaking and the plastic plug broke in half so i rethreaded for a bolt. Cut the bolt down, washed radiator out, and put the bolt on with pipe sealer so it can come off when i need it to.

1654423_415611201907357_1375126125_n.jpg1912486_415611341907343_1235469371_n.jpg

washed months ago1607000_415611421907335_1050273860_n.jpg

1939900_415611558573988_1077517370_n.jpg1619098_415611625240648_1674895484_n.jpg1948126_415611791907298_1665208369_n.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×