Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
dballs

My pickup tube is clogged with paper???

Recommended Posts

Update: Still holding strong pressure, 80 psi on startup. 40psi cruising. Hopefully the internals hold up for the long haul.

Share this post


Link to post
Share on other sites

Did you ask the guy who did the headgasket about it and show him your bucket of paper towel bits? If he was decent, the least he could offer is a 50k warranty on the engine. It's highly likely the rod bearings took a fair bit of damage, but they won't start knocking until they are really gone. On a non-turbo motor that can take a while.

Share this post


Link to post
Share on other sites

I asked him but he replied with "we don't use shop towels when we do head-gaskets" and I got nowhere. I think I am going to send the oil sample out to blackstone and have them take a look to see how much metal is in it.

Share this post


Link to post
Share on other sites

There is another port toward the rear of the block that can be used as well. And I think the thread on the rear port is 1/2" NPT.

I have been searching for this port to mount an oil pressure/temp sensor but could not find it. Could you give bit more precise description where it is located?

Share this post


Link to post
Share on other sites

i believe its on the back of the block..... ive read that it looks like either a big bolt or big allen head. **dont quote me on that as i dont know for sure**  there is one on the top of the block pass side towards the back but is hard to get to. there is like 4 or 5 of them around the block

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×