Jump to content
Ultimate Subaru Message Board
goat

check engine light and intermitent high idle

Recommended Posts

good day all

its been a while sincel was on here

 

but my sweetys 92 loyale is acting up

 

here is her description:

 

so for a while now the car seems to get stuck in high idle when I start it up and go down a big hill in first and second gear. It revs very high for a bit and then normalizes when I'm on the road in a higher gear.

It may be fine all day with no signs of problems, but lately it has been idleing erattically when I am sitting in traffic, higher then lower then higher then lower...etc rapidly. When it is doing this the check engine light comes on, but when I get going again the light turns off and the problem goes away.

 

l've been tryign to serarch but not finding many similar threads...

 

thoughts

sugestions

places to start

 

thanks

goat

Share this post


Link to post
Share on other sites

I had same type of idle issues w/ up and down idle when stopped an high idle when first started. I was not even using my A/C or heater when stopped because idle would be up/down or so high or so low that it would not charge battery right. Clean your IAC first if that does not work, check EBAY for a good deal. I just bought a reconditioned one for $50 W/ free shipping. It works just like it should mow... There are posts here on the subject sometimes hard to find. Hope this helps

Edited by superpoo93

Share this post


Link to post
Share on other sites

Is the idle real slow to respond, like if you rev it, it'll take a few seconds to come back down?

 

Could be a coolant temp sensor, or a vac leak of some kind... I know when my 91 Loyale is COLD (like 20F outside temp), it's a bit slow in bringing the idle back down when coming to a stop, until the blood starts flowing a little bit better..

Share this post


Link to post
Share on other sites

First check the codes there are connecters under the dash they are usually taped up there should be two sets of single connecters one set is black the other is green, connect the black connecters to get the codes. There are step by step instructions on the board do search and you should find them

Edit: here is the instructions for a legacy I think the loyals are similar but the connecters might not be under the dash.

http://www.surrealmirage.com/subaru/engine.html

Edited by mikaleda

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×