Jump to content
Ultimate Subaru Message Board

Recommended Posts

I replaced the front passenger axle on my 88gl 4wd 5spd 115k mi. because the boot was torn and slinging grease all over the engine compartment and on the exhaust.  I wasn't having any problems with the axle other wise(no noise, clicking,ticking).

 

So I got a remand from autohouseaz.com and put it in.  Checked axle to best of my ability before install and seemed fine, put it in tightened everything up and and took it for a test drive through my neighbor hood.

 

It makes a click/tick noise in sync with wheel speed ONLY while accelerating.  It is more noticeable turning right than it is left.  Again, it only happens when accelerating.  Let off the gas, goes away. Not accelerating and making a turn, no noise. Apply go fast(ish) pedal mid turn, starts clicking. Let off gas, goes away.

 

I jacked up the front passenger wheel and checked for any play side to side/up and down/in and out and everything is tight, no slop.  Spin the tire and no grinding or metal on metal sounds.  Removed the tire and break/rotor, nothing appeared amiss.  Removed castle nut and re-torqued it.  Took it for another test, still same issue. 

 

After reading through posts here I realize i should have just rebuilt the original Subaru axle seeing how i could have a bunk re-manufactured one.  Also I could have wheel bearings starting to go out.  I don't feel like wheel bearings could be the culprit only because I wasn't having any problems before replacing the axle. Checked the brakes and they spin just fine, no warpage or anything stuck in it or the tires.

 

My goal is to sell the vehicle because I just inherited a newish truck and do not need her anymore/dont have the room but I do not want to sell it with this issue present.

 

I'm perplexed as to why this only happens under acceleration.

Is it possible I didnt get the wheel bearings seated properly? the castle nut is ran up like thge drivers side so I assume they were properly seated.

 

Does any one know where to get an front passenger axle rebuild kit?  I would rather do the work myself and know its done right instead risking getting another crap axle. Also where to get the wheel bearings?

 

Thanks in advanced for y'alls responses 

Share this post


Link to post
Share on other sites

Most stress is on the axle when accelerating with the wheel turned. It's a bad axle. Exchange it for another bad axle, keep doing that dance a few more times and eventually you'll get a good one. You could try opening it up before installing it and packing new grease in.

Share this post


Link to post
Share on other sites

Before you start tearing things apart, recheck that you have the dished washer (between the split-conical piece and the axle nut) on properly, and then retorque the axle nut. The axle doesn't always pull tight into its seat when you install it, and this can cause the axle nut to lose torque and the axle to shift laterally in the hub, making all sorts of noises.

 

Quick thing to check, and doesn't cost you anything but a little time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×