Jump to content
Ultimate Subaru Message Board
marcusgl10z28

still have ny first subaru 86gl10 turbo

Recommended Posts

Turns out its the water pump and autozone shut down at 7 so gonna have to wait till Thursday... the soobi is strandad at work ... time to fire up the sleepy camaro...

 

Leaking out the weeping hole bad I'm starting to think that maybe my supposed head gasket failure may have been the weeping hole in the first place..and that the blue devil sealed it up.. for a short time...

 

I'm missing my wagon severly right now... the v8 just suked down 4gals in 30 mi... my wagon gets about 32 mpg hwy on long trips... usually about 28-30!!!...

Edited by marcusgl10z28

Share this post


Link to post
Share on other sites

I have been racking miles and fixing this as they come up... recent update on the wagon

tinted windows

6hG01Gp.jpg

then waterpump blew up!

UxafOVr.jpg

 

rear wheel brearings and seals... had to make a socket to get the retaining nut out of the hub... a 36mm w/ some bolts welded to it did the trick!!

GrES6Di.jpg

Dw861jU.jpg

interesting differance in parts

szZSjrC.jpg

ripped my exhaust off last time I went 4x4ing.. (rock)

EYiHIrv.jpg

g1Hgjzm.jpg

glueing it back together!!!

pDWqB8C.jpg

 done

wL9NJtI.jpg

 

engine was a little thirsty so I gave it some muddy water to drink(oops)

eobBPPt.jpg

then fabbed up a fix to keep water out thanks to a fellow bord members idea that I seen a wcss15 (panda wagon)

Ogk7E24.jpg

nvCxBTb.jpg

and attempted to clean the dirt out of my intake best I could and shot down the maf with some cleaner... iac is not happy at the moment but I got a replacement(thanks to kevin)

and a few other things just cant think of it off the top of my head. oh and just did plugs and wires today to maybe solve to go problem but sadly its still there.

 

I have developed a weird loss of power around 4500rpm... I think its fuel pressure related but ill look into that when I have time. I thought it was a miss but its a severe loss in power but only under long load times in that rpm... got me a little puzzled, im running an ea82t fuel pump... im thinking itr may be going or just cant supply my lead foot with enough go juice. anyone have this issue??

 

soon on its way... new axels again... fronts are again about to die. 6 inch lift if I can get ahold of anyone... but it will get done even if I have to make it myself, snorkel, maybe a bigger rack ill probably make it myself also and some tube bumpers and possibly rock sliders as my rockers are getting kinda rough... already got wheels in 6 lug after the lift ill drill the hubs out and swap a set of rollers I have on then go get some rubber... haven't decided on m/t or a/t tires yet... ive got a lot to do this February but it will all get done...

Edited by marcusgl10z28

Share this post


Link to post
Share on other sites

The car was running very lean so I went after the fuel pump... depesurized the system so didn't eat gas in my eye again... went to test fuel pressure unhooked the line at the engine and nothing... no residual gass at all... weird... then gas shot out of the input line of the ej...weird... ok.. so hook up the guage... engine starts...then dies...

 

I unhook the input line at the guage and try to prime the line... I can hear the ej fp relay and the fuel pump run and cycle... but no fuel coming out the line.

 

I remove the filter... still nothing...

 

Swap the pump with a known good pump. Fuel comes out of the lines for a sec then stops...weird.. ok so I hook up the pump and pour in 6 gallons of gas thinking I was out... still no fuel... put it on leval ground thinking maybe the slop is affecting it... still nothing!!!... looks like the hunt is on for some sort of clog.

 

Its war!!!!!! Next step I guess is to start chsing how far fuel is getting then y...

 

Is there an intank screen that I don't know of??

is there something I missed??? Does anyone know???.. has this happened befor??? I drove it to where it sits just got back from the wrecker and now it don't wanna work??? Holy crap!!! Frusterating!!!

  • Like 1

Share this post


Link to post
Share on other sites

got it all fired up... somehow there was an air bubble in the gas line btween the tank and f/p. hooked it all back up tested pressures fuel psi reads 23 psi while running... according to the specs that's pretty low... i dropped some octane booster in the tank last fill up.. and there is a very real differance in power. gonna grab a fuel pump from the wrecker this coming weekend unless someone has one they want to sell me???

 

this past saturday i grabbed steel for my 6 inch and tried cutting up today but the chop saw i have just isn't gonna "cut it"... its getting to hot.. so plan b take to where i got it from and have them cut it to bits for me.

 

Superbowl Sunday morning. i went to my local pnp and snatched up an ej25 block for my soon to be ej22/25 hybrid franken... (probably wont happen till June) its not number 1 on my list for now.. its not much to look at now but a close insp of the cylinder and haven't found any kind of scoring or rubbing or weird wear... actually it still has all the honing marks... she looks very nice inside! i'm stoked!!

 

looking to have a 6 inch this month... lets see if time and money can work its way into my life!!lol

 

also snagged up a pair of accord front springs to beef up the rear spring rate... no more sag and bouncy bouncy

 

hope fully with enough guidance and time and a little elbow grease i can get all this done in a short amount of time...hopefully 

Share this post


Link to post
Share on other sites

So i didnt do a 6 inch... decided on 7 inch front and 6 rear but rear honda springs added 2 incg so 8 rear... im tired...this took me 2 whole days with no sleep at all.. Its Been Rough ill Put up Pics Later On...

 

Big Thannks To Nick For Help During The Long Hours of Wreching... Thanks Also To Kevin And Dan At High Guys lifts.. Couldnt Have Done This Without All Ya Guys... and Now I Sleep

Edited by marcusgl10z28

Share this post


Link to post
Share on other sites

Here I'll put up the pics I took. 
The blocks we lifted it on for installing. Barely big enough. 
RXv0qPm.jpg

dropped the engine
rK6c3sN.jpg

on rubber!
IvHf89A.jpg

how marcus has to work on his car now. Or he could get stilts?
9RlA8YS.jpg

Share this post


Link to post
Share on other sites

nice build so far, mitsubishi wheels? i had some and the offset was near stock, loved it. looks like youre gonna need some skidplate action soon

Share this post


Link to post
Share on other sites

Did the steering link and i was kinda wingin it on the shift linkage but it all came out good and strong... a little tweek hear... some tubing there and magic!! Got my shifter back and all my gears...

 

No brakes cuz a banjo somehow came loose during the lift so now she needs a bleed.. car feels slow and wobbly.. im feeling that i may need an alignment and to go through all the bolts and nuts just to be sure

 

I didnt really take pics of the process cuz i didnt sleep at all for 3 days.. im still feelin it...

 

And yes the wheels are off a mitsu mighty max 4x4. Good eye. They are very close to a stock offset.. im not sure i like it though.. might be looking for some more offset like chevy pickup wheels or something.. its up in the air

Share this post


Link to post
Share on other sites

I  admire all the effort and determination you put into this wagon, its awesome!

BUT.... (just my opinion mindyou)

I personally would never lift a suby more than 2-4 inches,  its all they need.... lifting them this high ruins how they drive and rally while still being very capable off-road. yeah, now its way up there but forget handling, and all the under-guts are hanging out, the car was soooooo bad rump roast b4 you did this to it. it was AMAZING after the snow tires and green paint. now, not so much. hey you said be honest. I admire your work either way! nice stuff.

 

I honestly think though, if you put some skids (good ones) fixed the exaust, and put wider off-set wheels and meaty tires it will look sick!

Edited by AnotherGL10guy

Share this post


Link to post
Share on other sites

really? asuby site and we cant even say the word "ARSE"? its an animal for christ sake LOL...

So as much as i hate to agree... i do.. handling is suffering and i admit that its wobbly and feels unstable... ask anyone that tried to kepp up with me befor this lift.. they couldnt.. the car was much faster and felt much more stable and could actually hold its own in the corners...if i cant get ghe car close to that again after a frankin and some suspention stuff.. im gonna drop it down to a 4 inch...

 

Im thinking i may have gone ovrrboard but ill see what i can do about stabalizing it more...

 

Thank you for your input i do apriciate it..really

Edited by marcusgl10z28

Share this post


Link to post
Share on other sites

It will handle a lot better with wider offset rims. the car is too tall for how skinny the track width is. of course it feels sketchy. My impreza is lifted 6" and my tires stick past the fender 2-3" and its PLANTED in corners. Yes you can't rally as fast anymore but you can still drive reasonably without flipping over. Can you mock up a rear sway bar by connecting the rear lift blocks? im not sure how EA lifts work in the rear, but that's an option for EJ guys. maybe a rear strut bar? An alignment is definitely going to help for starters.

 

I think the car looks awesome, good job!
 

Share this post


Link to post
Share on other sites

Lifetime alignment at firestone done on friday.. felt better... exhsust done friday night sounds and looks better. Junped it a couple times and hit lots of bumps and it settled in quite nice.. shes feeling alot better. Just needed time to work the parts in. Im not gonna drop it and ill be looking into more offest

Share this post


Link to post
Share on other sites

Tahuya trip really killed the new alignment and my front blocks are loose. The ej is acting funny. But im thinking knock sensor thanks to northcoast! Cat is clogged good.. i guess i didnt gut it good enough. Im gonna swap a 5mt d/r in.. my ft4wd 5mt just isnt turning tires like i would like... i smoked the clutch good but im thinking legacy automatic in the future with a vlsd out rear... time to do some reading.

Share this post


Link to post
Share on other sites

So after a load of reading... and process of elimination.. it was the maf... swapped with a known good maf and magic... got the top end back obd now it powers up hills almost like she did with the 27" tires... front end still picks up alot and i still have alot of passing power!... running no sway bar now... lots of body roll but never even thinks of breaking loose... the ej will still roast tires in the wet.. new springs out back make me forget i have a bunch of crap in the back..cuz it dont sag at all... im liking this biuld and im using it as a dd and its quite comfy as well.

Share this post


Link to post
Share on other sites

Rx ft4wd d/r trans + frankinmotor???... anyone have an opinion on this pair?. I hear that the rx trans is weak and cant hold up... i know its low rang isnt as low its brother but its a nice setup in my head anyways... somone please chime in

Share this post


Link to post
Share on other sites

So... my clutch is gone... forever.. i ordered up a new one with liftime warrenty and snagged up a dual range while i was at it... i must regear asap!

Share this post


Link to post
Share on other sites

wow i havent posed for a while...i gotta update this alot has happened. hahaha... the lift really just takes some getting used to ... i roll with no sway bar and id like to see any stock gl try and keep up...lol... did a dr 5 spd also... dropped my gear ratios alot for the 3.7 final i had... ill admit i hate 2wd for arount town stuff but im getting about 25.26 roughly mpg ...down from 30-31... but still better than any other car ive owned.

Edited by marcusgl10z28
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×