Jump to content
Ultimate Subaru Message Board
duffymaddox

Need Help 95 Legacy low idle and vibration at 45+ mph...

Recommended Posts

Hello, I got a 95 legacy from my sister last year Since then I have replaced MAF sensor. and just yesterday had to replace the harmonic balancer (Crankshaft Pully) got loose and reamed out the inside of itself . I know that i have a hole in my exhaust . could that be the cause of my idle issues or should i also look elsewhere. and why does my car vibrate at 45+ mph

Share this post


Link to post
Share on other sites

Most of the time a vibration at speed is because the tires are out of balance.

 

Low idle can be due to several reasons. Usually it's a vacuum leak. Check the small vacuum hoses that run around on the intake manifold for cracks and splits.

Share this post


Link to post
Share on other sites

The old crank pully was wobbled but i replaced it with a new one it fine i could not get the crank sprocket off to change out the woodruff key ( cause i dont have a puller and did not want to damage anything so i used the old key the pulley went on nice and tight. i made sure that i put the timing belt on withe all the sprokets at center but the left side cam sprocket drifted about a 1/4 in off center but there was a lot of play on that side so I did not think that would matter. I also know that the spring inside the pcv valve does not seem to engage all the way.

Edited by duffymaddox

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×