Jump to content
Ultimate Subaru Message Board

Recommended Posts

My 99 OBW climate control buttons for air flow direction don't work. Press any button on the dash controller, and the air flow is always from the dash vents. Heater lever and motor fan controls work just fine. I couldn't find any write ups on this in the "search " section.  Any dvise??

Share this post


Link to post
Share on other sites

Either soda or other spilled drink has gotten into the control unit or you have a bad mode door actuator.  There was a thread in the last week or so about cleaning the buttons.

Share this post


Link to post
Share on other sites

Either soda or other spilled drink has gotten into the control unit or you have a bad mode door actuator.  There was a thread in the last week or so about cleaning the buttons.

Yes, I remember the thread about cleaning the buttons. I think I replied to that with cleaning advise. My buttons are not sticking, I see no evidence of soda residue.  What is a mode door acuator? Is that the dashboard contol HVAC unit??

Share this post


Link to post
Share on other sites

The mode door actuator is the electric motor that changes the settings on the heater box itself.  Its way up under the dash at the top of the heater box itself.  I can snap you a picture of the piece this evening after work. I have the dash out of my second 97 legacy so the actuator is in easy view.

Share this post


Link to post
Share on other sites

Update.........upon further investigation, I did see where some sticky soda residue was around the HVAC buttons. I can thank my daughter for that. I cleaned the buttons off well with Windex, and wiped off with a paper towell, but air output is still only through dash vents. In the past I have gotten the Windex to work well, but not today.

 

I had a similar problem with my 98 OBW, and fixed that with a replacement HVAC dashboard controller from a wrecking yard. Maybe I need to do that again. I spotted one at a local pull-a-part recently, so I will snag that one.

 

The mode door actuator sounds difficult to reach on top of the heater box. I would prefer not to replace the unit, without first seeing if a new dashboard controller fixes the problem.

 

Thanks 86Bratman for the offer of the picture. I will get back to you, if and when I need a picture.

 

Thanks guys.....................Larry (Rooster2)

Share this post


Link to post
Share on other sites

Do the LEDs under the mode buttons light up when the mode is selected? If the LEDs don't light up id suspect the control head to be bad.

The mode actuator gets its power from the control head, check the fuses before replacing the control head.

  • Like 1

Share this post


Link to post
Share on other sites

Final update............I removed dash panels to check wiring on back of dah control unit. Just for giggles, I sprayed heavily again with Windex, kept pushing all the buttons, and wiping away the Windex with a paper towel. This time, the cleaning worked. I got all buttons to work, and I could see the flap move behind the dash air outlets, to know the flap was opening and closing. I am amazed that so little dried Coke sugar syrup can disrupt the selector buttons from working properly. So all is well.......saves me a trip to a yard to buy a replacement control unit.

 

Thanks again for all the sound advise................Larry (Rooster2)

Share this post


Link to post
Share on other sites

Good to hear you got it working. Only have to get a small amount of sticky drink behind ONE of the buttons and the rest will not work. If one button stays stuck on the mode will not change.

Share this post


Link to post
Share on other sites

Either soda or other spilled drink has gotten into the control unit or you have a bad mode door actuator.  There was a thread in the last week or so about cleaning the buttons.

Can anyone link me to this thread?

Share this post


Link to post
Share on other sites

I have this same problem on my '99 Outback. I tried cleaning my controller, replacing it. No success. It was a gradual problem. The mode door would move fairly slowly at first, now it's stuck at defrost. Am I right to say it's most likely the mode door acuator? If so, is there any way to replace it without removing the entire dashboard? Thanks for any help you can provide!

  • Like 1

Share this post


Link to post
Share on other sites

I have the same problem in my '98 Legacy Brighton......I sprayed 70% Isopropyl alcohol at it and then sprayed canned air duster to blow it in there, worked the buttons, still not functioning correctly, the defrost button when depressed engages the A/C compressor normally but no air from the defrost, mine is stuck on vent/floor now. 285,000 miles and counting......

Share this post


Link to post
Share on other sites

We have a 99 outback and are original ownders. I am having the same issue but do not have any soda buildup as we have had the vehicle since brand new and never drink pop and haven't used the drink holder for a very long time. The buttons seems to push just fine and the led lights work as well. we have wiggles the wiring  and the blending door still just stays open so we only get air blowing out the from vents. Winter is upon us and we need to resolve this issue before icy weather requires defrost setting which currently do not work. We were figuring that it is probably the actuator but wondered like  someone above if it requires removing the whole dash? Any help would be appreciated there is sure a lack of information on this on the web.

  • Like 1

Share this post


Link to post
Share on other sites

After some research I've determined that it definitely requires the entire dash to be removed. The mode actuator is on the left hand side of the heater unit. That's behind the dials. That's one reason. The other reason is that I haven't been able to find just the mode actuator. It's only sold as part of the entire unit, a $250 unit. Don't think I'm gonna bother fixing it anytime soon.

Share this post


Link to post
Share on other sites

We have a 99 outback and are original ownders. I am having the same issue but do not have any soda buildup as we have had the vehicle since brand new and never drink pop and haven't used the drink holder for a very long time. The buttons seems to push just fine and the led lights work as well. we have wiggles the wiring  and the blending door still just stays open so we only get air blowing out the from vents. Winter is upon us and we need to resolve this issue before icy weather requires defrost setting which currently do not work. We were figuring that it is probably the actuator but wondered like  someone above if it requires removing the whole dash? Any help would be appreciated there is sure a lack of information on this on the web.

If by saying "actuator" you mean the push button climate control unit, then I may be of help. I wrote this thread back in September of 13. Snce then, I have replaced the actuator on both my 98 and 99 OBWs. They are the same unit. The dash does not need to be removed to replace the actuator. Just remove the plastic trim pieces around the actuator. The actuator is held in with screws at all four corners. Easy enough to remove. The temp slide cable connector is somewhat difficult to remove, but can be done at the actuator with a lot of patience, but have heard that it is easier to remove at the lower end. Two electrical connectors are easy to remove.

 

I have seen replacement units sold on e-bay, or available at a wrecking yard. A yard is where I got mine. Burnt out light bulbs can be replaced. Somewhare on this forum, someone described how to do that.

Share this post


Link to post
Share on other sites

A blend door actuator is what it sounds like he is referring to not the HVAC controls.

 

The actuator is essentially the motor that controls the blend doors to move where the air is flowing or what temperature the air coming out is.

 

And most cars require a lot of tear down to get them out.

Share this post


Link to post
Share on other sites

Not if you are creative ;)

 

I can wish.  I have to do the rear HVAC Assembly on my Durango due to a blend door actually breaking (it happens more than people know).  I have to tear out the entire rear passenger side interior to get to the thing, evac the AC, and drain the rear heater core.

 

It all depends on the car, but most of them require a lot of tear down just to get access.

Share this post


Link to post
Share on other sites

I can wish. I have to do the rear HVAC Assembly on my Durango due to a blend door actually breaking (it happens more than people know). I have to tear out the entire rear passenger side interior to get to the thing, evac the AC, and drain the rear heater core.

 

It all depends on the car, but most of them require a lot of tear down just to get access.

Your right, it does depened on the car, but if your creative you can do it. I've made special tools to get to that one screw you can't see. Its always a gamble sometimes you go over book time sometimes it works out better.

Share this post


Link to post
Share on other sites

Do the LEDs under the mode buttons light up when the mode is selected? If the LEDs don't light up id suspect the control head to be bad.

The mode actuator gets its power from the control head, check the fuses before replacing the control head.

A big thanks.  Sprayed windex between buttons on my 98 outback.  Before only 1 light worked, now they all do.  Plus got back air through the centre vents.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×