Jump to content
Ultimate Subaru Message Board

Recommended Posts

Alsalam Alaykom and Good day,

 

i am seeking for knowledge as it is not found anywhere around, i have several problem with my 97 Subaru Impreza "FWD-1.6" which i really love so much, and i was hoping to find some answers in here as even in the internet haven't much related to my car:

 

  1. when i am on the first gear, and raise my foot gently to make the car moves "without using acceleration" the whole engine shakes real bad, and to over come on this problem, i have to use the acceleration, which i don't consider normal as i have driven so much cars that could drive without using the acceleration, although there's a little shake in the other gears, but the first gear is the worst experience, so i was hoping for some answers regarding this matter, what trouble shooting i should do.
  2. i would like to have a full map for all the sensors for 97 Subaru Impreza "FWD-1.6" with the function of each one, and how to check on them.
  3. in winter, when its cold, the engine temp. decrease so much, and i don't know the reason for that.
  4. the engine sound is so loud, like lots of loud quick "tic-tic-tic-tic", is this normal in subaru world?
  5. what are the things that i suppose to check from time to time, and what should be replaced after exact time or km

 

 

i really appreciate your time for just reading my problems, and i am hoping to hear from anyone that might help me, as you don't know how much this car means to me, it's love

Share this post


Link to post
Share on other sites

Welcome to the USMB.

 

Is your Impreza a manual transmission?  Does the shaking occur at all rpms when in 1st gear and you let off the accelerator or only after the engine revs get above a certain point? 

 

Do you know if your 1.6 liter engine is fuel injected or carbureted?  We did not get the 1.6 liter engine in North America so I'm not sure what info we have is going to be similar.  However, here is the Subaru factory service manual for the US 97 Impreza.

http://www.main.experiencetherave.com/subaru_manual_scans/FSM_Scans/1997_Impreza_FSM.zip

 

If you're having engine temp issues, I would probably recommend checking the engine's thermostat.  Subaru engines tend to be picky about the thermostats used and you should try and get a new one from Subaru.  Most of the aftermarket thermostats from parts stores don't work properly.

 

The ticking is probably from the hydraulic valve lash adjusters.  Have you checked your oil level recently?  Also, when has the oil last been changed?  Usually you will noticing the lifters ticking more when the oil is dirty or low.

 

Take a look at the factory manual as it has maintenance schedules in there and things that should be done. 

 

If you have questions, post back.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×