Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
nick1208

94 Loyale won't idle well

Recommended Posts

I've just recently been experiencing problems after an offroad trip. Looking for what the source could be. At idle occasionally it will hold idle at around 1,000 rpm (not unusual for my car, which usually idles around 800). But sometimes it will sound like its bogging down and jump down to 200-300rpm and i will have to give it some gas to prevent it from not killing itself. The only thing that i've done to arouse any problems recently is the offroad trip and take my muffler off. I got home today and opened up my hood and I heard some hissing off and on. Could it be a hose leak that's causing problems? 

Share this post


Link to post
Share on other sites

If also the use of any auxiliary feature such as electric windows, lights, cigarette lighter, also causes the engine to bogg, then you might need a new alternator.

Share this post


Link to post
Share on other sites

Nick, the manifold bolts may need tightened or go get some intake gaskets and drive over here. most likely a vac leak though. start spraying carb cleaner at different spots. youll find it

Share this post


Link to post
Share on other sites

Nick, the manifold bolts may need tightened or go get some intake gaskets and drive over here. most likely a vac leak though. start spraying carb cleaner at different spots. youll find it

lol this is an older thread. Idle is all good now. I forget what I did to fix it...hopefully I can finish my car before wcss

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×