Jump to content
Ultimate Subaru Message Board
Danja44

Need help with carb'd EA82!

Recommended Posts

I am getting a bit of a tapping sound like valves or almost a dieseling noise under acceleration with a load.

 

Also, its been running lean since I've owned it. The plugs come out white.

 

Any Ideas??

 

 

Share this post


Link to post
Share on other sites

probably spark knock.  its common for people to jack up the timing so double check it.  if you know its running lean then that can cause it as well, you probably need to clean and adjust the carb.

 

put some 92 octane in it and see if the noise changes.

Share this post


Link to post
Share on other sites

I'll double check the timing when I do the valves this weekend.

 

I know the carb is clean, I rebuilt it about a month ago and cleaned it up really good. Couldn't get the jets out so I just blew them out as best as I could.

 

Would a plugged up exhaust play a role in it running lean?

Share this post


Link to post
Share on other sites

ea82s have hydaulic lifters and do not require valve adjustments. make sure youre not a tooth off on the tbelt.

 

 

if not, time for seafoam

  • Like 1

Share this post


Link to post
Share on other sites

Awesome! I didn't wanna check valves clearances anyways! Haha.

 

I'll be sure to check all the timing marks this weekend. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×