Jump to content
Ultimate Subaru Message Board
JustGo_GL

84 GL Wagon - Ignition/Starter/Battery problem

Recommended Posts

Sorry to hear that. If you have good grounds, good battery cables and a good ignition switch I would think you are covered. I remember now having another similar problem 10 years or so ago. I ended up installing new battery cables, needed it I am sure but made little difference, a reman starter with same results. Finally I traced the hot wire from the ignition, were the pink connector plugs in, and replaced it from the connector all the way to the starter. That fixed it until the ignition switch went on the blink. I was prepared to replace everything I could one wire at a time, lol!  On cars this old most everything you do probably needed to be done anyways. Just gets aggravating some times. I think the ignition switch is the last thing I have had trouble with and that has been nearly three years ago, knock on wood!!! Good luck.

  • Like 1

Share this post


Link to post
Share on other sites

Just curious, what happens if you start an automatic while it's in drive?

 

Car moves on a cold start w/o brakes applied.

  • Like 1

Share this post


Link to post
Share on other sites

Hopefully you have cleaned the battery connections already. One common problem area for this kind of thing is the connector for the ignition switch. Look for signs of burning at the connector. Make sure the fusible links are making solid connection. If power seems to be okay to everything except the starter circuit then the safety switch is a good bet for the trouble. Get at least a test light probe so you can verify where power is getting to while you are having the trouble. Find out which dash fuse suppies power to the stater solenoid and make sure power is getting to it while the trouble is happening. Use the slits on top of the fuse to check for power.

Share this post


Link to post
Share on other sites

Wow, play the lottery that day? haha

 

I'm interested to see how this goes as my girlfriend's Loyale has done the same thing since we got it 5 years ago. I've jumped through a few hoops trying to figure it out but still haven't. It doesn't do it *too* often but it's annoying when it happens.

 

Usually I'll just keep trying to start the car over and over again and eventually on the 50th or 100th try it'll turn over, but by then I've gotten so in to the routine of turning the key off and on quickly I'll turn it off while it's cranking and then the next key turn it's back to *CLICK* lol

 

I'm not so sure it's the same issue though as I'm certain the click I get when it won't start is under the hood and there is no even slight attempt at engaging the starter motor. Just a click.

 

Also! Are you ever around Hoboken? If you're in Jersey often we should meet up and take pictures of our old cars society shuns.

 

Cheers!

 

I have had the same problem with my 1990 Loyale. Clicking sound comes from the hood area. Replaced the starter and battery is good. Every other time I try to start the car just clicking and no attempt to turn over. It always eventually starts and runs great. I will let you know if I find a solution. 

Share this post


Link to post
Share on other sites

Another thing that can cause this, as I have had it happen to me a few times now, is the negative cable.  It may look fine on the outside, but over time, they start to break down inside.  Everything else on the car will run fine through it, but once you hit it with the load of the starter it just will not handle it.  I solved this by adding a new dedicated ground cable to the bolt on the starter mounting flange.

 

You can test this by hooking a jumper cable to the stud on the starter and the other end directly on the battery negative.

 

-Adam-

Share this post


Link to post
Share on other sites

Sounds like your stater is shot. I had the same problem with mine and I replaced my thirty year old starter with a reconditioned one and it works great now

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×