Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
AKghandi

I found it!

Recommended Posts

So for a long time i have wanted a late 80's gl with a dual range. Its an 1989 gl!

 and its perfect.

 

sZMzjc.jpg

 

z8m9KB.jpg

 

l1B7hF.jpg

 

 

It has almost no rust!!!! i cant believe there is no rust.

 

its a dual range SPFI with power everything and even has A/C that was retrofitted for R134a.

 

I have many plans for it but first we make it run good, its running pretty rough, I'm sure its nothing major.

not ticks or knocks just a little gutless and a rough idle.

 

 

after i get it running good a year correct bumper is in order, somehow during its life someone put an 85/86 bumper on it.

the front end needs a bit of work and there are a few dents that need adressed but over all i couldn't be happier!

 

 

I'ts getting lifted.. how much I'm not sure yet. probably just 2" and some slightly bigger tires just to keep it more street-able unlike my 85 wagon which is super slow.

Edited by AKghandi
  • Like 1

Share this post


Link to post
Share on other sites

I don't know, I'd keep the 85/86 bumper. We only ever got these in NZ, and I much prefer the flush indicators to the recessed ones - I'm not a fan of the USDM extended bumper look. But each to their own I suppose.

 

Sweet find anyway, love that colour.

Share this post


Link to post
Share on other sites

Oh yes it must have been garaged and washed often its amazing..

 

The bumper thats on it is pretty mangled. And while i like the flush indicators i also like the heft of the later bumpers. Plus its going to get a little winch mounted

Edited by AKghandi
  • Like 1

Share this post


Link to post
Share on other sites

Well i got the car in my name and registered today.

 

I'm starting to narrow down the running issues.

 

first, it idles smooth but the engine shakes very rhythmically the idle doesnt change just a slight shake.

My guess is cam timing is off.

 

second when you drive it some what aggressively or up a hill or around a sharp corner it will bog down and pop and sputter. my guess since there isnt a gas cap is that the tank is full of water. 

 

 

Also this car drives better than any other subaru i have ever driven, hell it drives better than my girlfriends 08 focus

Share this post


Link to post
Share on other sites

I like the bosozoku exhaust thing going on with the tailpipe...lol.

That is just a pipe leaning on the other car.  Look closely and you can clearly see the exhaust stop @ the bumper.

Edited by Mykeys Toy

Share this post


Link to post
Share on other sites

That is just a pipe leaning on the other car.  Look closely and you can clearly see the exhaust stop @ the bumper.

 that would actually be a floor jack under the front of the cadillac

Share this post


Link to post
Share on other sites

Take good care of it and it will do the same for you. ;)

 

 i intend to.its actually nice enough to EJ.

Edited by AKghandi

Share this post


Link to post
Share on other sites

So i did some more work to the car today, I put the passenger door panel back together, then i put the new oil pressure sending unit in.

 

the car will need a new oil pump gasket  as it leaks quite a bit.

 

I plan on a new oil pump gasket and a new timing component kit.

 

but first i need to drain the gas tank and see where the filler neck is leaking from. it didnt leak a lot but it did leak.

 

i suspect with fresh gas and proper timing the car should run perfect.

 

I cant wait! in just the short drive to DMV and back even with the poor running i still fell in love with it.

 

I really cant express how well this car drives. 

 

It does have a bit of an odd quirk.. occasionally it doesn't engage reverse. if i let the clutch out a little it will grind then engage.

 

Not sure if its linkage or actually a trans problem.

Share this post


Link to post
Share on other sites

Time for an update as its been a month and the car hasnt moved.

 

I drained the gas tank and put fresh gas in it but that didnt seem to help.

 

So i got a new fuel pump.. it was a carter box with an airtex PN

but in the box was a genuine subaru pump! 

 

 

I also got the oil pump seal

 

oRIa6U.jpg

 

 

and I also got a parts car, 1988 DL spfi 4wd

dem quads

 

hapq78.jpg

 

 

The DL has a bad timing belt and A LOT of rust.

mXaykp.jpg

 

 

So in a few days I will be stripping every thing off the DL and putting most of the parts in storage.

the quad headlights and the front bumper will be going on my car and the engine will be going in my brothers wag.

Edited by AKghandi

Share this post


Link to post
Share on other sites

I am very irritated..

 

Today I replaced everything, fuel pump, filter,pump relay. injector, FPR, IACV, CTS, MAF, ,distributor,coil,isolator, even the ECM.

 

it got a complete igniton tune up with new cap rotor wires and plugs.

 

the problem still persists.

 

 

I have no idea where to go from here. the only other thing i can think of is maybe the cam timing being off is causing it.

or that the intake mani gaskets are the problem

 

or maybe its a bad gas pickup.. but when i pulled the pump gas flowed out of the feed like Niagara

 

 

the issue is it will run just fine for a while, but then pop and sputter buck and lose power, like its running out of gas.

 

Tomorow i plan on replacing the intake manifold gaskets and the gas tank and filler neck, i know the filler leaks so i figure might as well do the tank too.

 

 

I need help.. please. someone. before I light it on fire..

Edited by AKghandi

Share this post


Link to post
Share on other sites

So after some research ive decided to change the tps also. After that ill start looking for mechanical problems.

 

Do these have a knock sensor? And where might it be

Share this post


Link to post
Share on other sites
So today I decided.. screw it.

 

Im swapping the engine.

 

 

Pulling the engine from the parts car

5iAjHi.jpg

 

Engine pulled. the timing belt was stripped.

 

wRrHxe.jpg

 

Cleaning it up a bit.

 

6FiicP.jpg

fohh9o.jpg

 

Covers gone. new oil pump gasket, and new valve cover gaskets. the lifter pressure release valve was just sitting in the head and it fell out so that will have to be addressed. the spring and bolt is there and I suspect the ball bearing is in the oil pan.

 

ZqY5O6.jpg

 

 

Tomorrow I will be cleaning it up some more and putting on the new timing kit and friday I'll throw it in.

 

 

trying to decide if i want to paint some stuff and make it look better..

Edited by AKghandi

Share this post


Link to post
Share on other sites

I suppose I should probably explain why I'm swapping the engine.

 

the engine thats in it right now leaks like the xon valdez.. from everywhere. including the head.

 

there is something mechanical wrong inside the motor. not sure what all but i know that its at least a headgasket.

the  #3 cyl spark plug was bright and shiny, and the rest were semi normal and there is a rather quick coolant loss

 

the coolant wasnt milkshake but it wasnt bright green, kind of like a seafoam green....i cant believe i know what seafoam green is..

 

 

there is also a pretty scary TINK kinda noise when its doing its little bucking routine. not spark knock or ping but something mechanical..

 

 

 

so i figured with it needing a reseal, new timing kit, and mos likely a new headgasket or head.

 

why not just do this all to a different motor that was known to be good and put it in instead.

 

not like a motor swap on these cars is real hard :P

 

 

 

 

 

 

 

I feel like I'm talking to myself.. hmm..

Share this post


Link to post
Share on other sites

 

 

I feel like I'm talking to myself.. hmm..

I know that feeling...it doesn't seem like people want to respond to build threads with too many technical details in this section.

Share this post


Link to post
Share on other sites

so today i got my lazy butt out of bed and went and put a new oil pan gasket on the new motor and a fresh timing kit. motor has great compression.

 

not as clean as i would like but i dont exactly have the best cleaning suplies... degreaser a small wire brush and a hose with cold water..

 

after its in the car and running i'll take it to the car wash and clean the bejeasus out of it.

Edited by AKghandi
  • Like 1

Share this post


Link to post
Share on other sites

So today I completed the engine swap. no big hang ups aside from a few derps on my part.

 

and now pics!

 

pulling the old engine

Gh2TLF.jpg
 
 new engine waiting to be put in
tSmYDD.jpg
 
 
We cut the roof off the parts car to have a nice work station
 
Xsh3r6.jpg
 
old engine out
 
jbx8AO.jpg
 
lots of muck in the timing covers
 
m3Yfg3.jpg
 
Cleaning the engine bay
 
uhPRXr.jpg
 
cleaner..
 
lRfQPt.jpg
 
threw some paint on the crossmember
 
LduWO7.jpg
 
new engine, ready to be put in.... yeah fram filter i know but i had a new one laying around so i made the best of it.
 
gMXybt.jpg
 
engine back in and running!!!!!!
 
Owf5Nv.jpg
 
and we duct taped the roof back on the parts car to have some where to store the old engine.
 
ssflAQ.jpg
 
 
 
 
 
now that the engine has been replaced it has gobs more power and hasn't acted up yet. I haven't driven alot yet but things are looking good.
 
 
i took off from a stop and i thought the clutch was slipping... turns out i was spinning the tires...
Edited by AKghandi
  • Like 1

Share this post


Link to post
Share on other sites

So that concludes part one. getting it running right.

 

part two will be dealing with a leaking wheel cyl on the drivers rear, and putting new shoes on

fixing the door latches and hooking everything up properly. there are a few odd quirks. like some time the drivers lock wont unlock the door but will unlock the others, and if you turn the key a little harder it will open the door..

fixing the windows they all work, but they dont all work from the drivers panel. probably just need a rebuild.

and putting on the quads.

 

not all in that order.

 

 

part three will be lift and tires... I'm excited!

not sure how much lift I want. I'm thinking 2" but at the same time 4" would be fun...

I have however decided on tires already. general grabber at2 27x8.5 r14's

 

 

have not decided on what part 4 will be. probably fixing up the body a bit

Share this post


Link to post
Share on other sites

Lol at the duck taped roof. I'd love to go to inspection with that set up. Sounds like the engine swap went well! If you could document the quad light swap that'd be awesome. There's lots of people that want to do that swap that don't know all that's involved.

Share this post


Link to post
Share on other sites

I will try my best, I know that I plan on running a whole new bank of relays so that when high beams are on all 4 come on. with nice clean power straight from the battery.

 

the wiring will be the fun part, the actual mounting is easy. hell the body already has all the threaded holes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×