Jump to content
Ultimate Subaru Message Board
sporta

Lack of acceleration

Recommended Posts

Hello all

 

Been a while since i have been on these boards, but now i need a question answered. I have a 88 DL fwd EA82 that has about 195k on the motor and it will not get out of its own way from a stop sign/light. when you press on the gas there is a massive amount of hesitation.....almost like it is starving for fuel...if you sorta pump the accelerator, it will start off slow and then pick up.....ok here is the question:

 

Could the above symptons be a sign of poor fuel pressure? meaning failing or bad pump ? or is it an injector problem ? or filter someplace in the system?

 

:-\ any ideas where to start ?

 

Thanks

 

Steve

Share this post


Link to post
Share on other sites

My GL never did accelerate? :confused:

 

Even when it was running good!:lol:

 

I'd give it a basic tuneup and see what happens.

For my old hatch a Cap and wires fixed everything evertime.

When was the last time the filters were replaced?

 

For what it's worth,

Glenn

82 SubaruHummer, never did accelerate!

01 Forester, just plain fast!

Share this post


Link to post
Share on other sites

Glenn,

 

 

I deffinately know that my DL will never be a power house, but, when you floor it to get going ther is a delay b4 moving will check the main filter for replacement date tune up was bout 9 months ago with cap wires and roter...

 

thanks

 

Steve

Share this post


Link to post
Share on other sites

well, i had a plugged cat on a pickup that did the same thing..but could be fuel, vacuum leak, fouled plugs, etc.. good luck..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×