Jump to content

Recommended Posts

Hey everyone. Ok, so I get off work one day, and figured I should stop and get engine oil and filter before I head home to do my standard maintinence on my 1995 legacy L. While I'm stopped in the parking lot, I'm noticing a large amount of smoke coming out of my engine bay. I turn off the vehicle and get out to look underneath. I find a very large amount of ATF leaking onto my cat. I immediately call for a tow truck so I can diagnose the issue at home.

I've searched a huge amount of forums regarding the 4eat, leaks, problems, and so forth. I can't find much.

Other than, by where the fluid is draining out, it's most likely my rear driveshaft seal.

I was just wondering if anyone else has had this type of experience, or knows if it's even worth fixing.

Thank you!

Share this post


Link to post
Share on other sites

$10 seal takes maybe 45 minutes to replace it.

 

Pull the driveshaft off and make sure the front U-joint isn't locked up. If the u-joint is bad it can make the shaft wobble and ruin the seal and the bushing in the tail housing. If the bushing is damaged you'll need a used tail housing.

 

Probably just the seal went bad, but worth a couple minutes to check those things to be sure.

Edited by Fairtax4me

Share this post


Link to post
Share on other sites

i had my rear seal ''blow out'' of my 95 while driving on the hiway.

there was a shudder and a bang.

 

i drove straight to a shop and had the seal replaced.

later in the evening my car would not back up, no reverse.

i bought trans fluid and added 3 qts.

and drove back to the shop.

the dumb a$$ replaced the seal but did not add any fluid.

he said the dip stick read full.

dumb a$$.

 

so the answer to your question is,

it all depends on how much fluid lost and how long it was fluid starved.

if you do the woirk yourself it would not cost much to find out.

 

i drove my 95 for several months with no reverse.

it never progressed or got any worse,

and some times reverse would actually catch and work.

but i had to be really carefull where i parked.

 

good luck.

Edited by johnceggleston

Share this post


Link to post
Share on other sites

thank you everyone. It didn't blow out while on the road. It's just leaking horribly. Seems like a pretty easy fix, how complicated is it to seat the new seal in there properly? Could I find a different thread, or any tricks somewhere??

Share this post


Link to post
Share on other sites

First clean and find the source of the leak!

- hoses

- rear seal

- front input shaft seal

 

If you can get it up on a rack, it will be much easier.

  • Like 1

Share this post


Link to post
Share on other sites

I'd drain all the fluid out (wouldn't worry about what's in the actual converter) and add fresh trans fluid (it's been superseded since car was made, so go with newest fluid you can find) and refill after seal is replaced. Start engine and run it through the gears D,3,2,1, and R, then N, then repeat a few more times (do NOT drive it or move it). With engine still running, check trans stick. You can ballpark how much to add initially by subtracting what should be in the converter from what was drained. Add a little more and run through the gears again. Also worth checking if it's leaking at the seal again or not.

 

Keep doing this until it's reading on the stick. I suggest staying a touch under the stick line than adding too much. Once it's close to the line and you've made plenty of redundant stick wipe, insert, pull, check, repeat, and it's been through each gear, etc. and almost on the line, take a for a quick, calm ride around the block, then check stick again and add enough to get it on the line.

 

Trans shouldn't slip, or take long to enter gears. If it starts slipping, takes forever to go into gear after selector was moved, etc. it might have damage. Otherwise, if all goes well, give a few days of driving, then drain and replace fluid again, as this will hopefully be enough time for the OLD fluid in the converter to mix with the fresh fluid added, and by draining and refilling, it'd should be fairly fresh. Could do this again in 6 months just to be safe. The older these trans get, and the more miles added, the fresher the fluid you should be proactively adding to keep it happy, as fresh fluid will have friction and seal additives, etc. and will be less prone to premature failures from heat, slipping, etc.

Share this post


Link to post
Share on other sites

Wow! Thank you for the rundown. I really appreciate it. I'm very confident it's the rear output shaft seal. Easy fix. Then I will follow exactly the steps you mentioned. Thank you so much

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×