Jump to content
Ultimate Subaru Message Board
aba4430

87 Brat - Dealer Installed AC Question (semi-long post)

Recommended Posts

My original R12 system stopped working sometime ago, so I verified that my compressor was OK by jumping it. Initially I wanted to do it the right way by replacing the o-rings and drier etc. After I disconnected the low side fitting on the compressor and noted that the o-ring was in good shape, I took the easy way out. I rented a vacuum pump this week-end for $20 and yesterday evacuated the system out or thought I was doing this anyways. Note that this was my first attempt at AC work. However, I did not check the guage readings for vacuum, just thought I was evacuating the system. I charged up a quick kit and went for a drive. The AC cooled to 38 degrees in no time and it felt great. I returned home and popped the hood open and could hear a hissing sound. Found out that the hose from the evaporator to the compressor had a good leak on it. So much for this attempt.

 

However, called Advance and Autozone this morning and they do not carry replacement hoses and cannot even special order any. So I bought a Haynes AC book and also went to Home depot and bought a 5/8" 180 degree brass barbed hose fitting. I repaired the damaged hose by using the barbed fitting and 2 hose clamps. Then I evacuated the system again (high and low pressure sides). This time, the low pressure guage read about 28 on the vacuum side and the high pressure guage was below 0. Amazing, I wish I was more careful yesterday. Anyway, checked that there were no leaks by putting system under vacuum for 5 minutes and then evacuating again for 30 minutes (Haynes instructions).

 

Thereafter I charged the system up with Ester oil, 2 cans of R134A and a 3 oz can of dye and leak sealer. The low pressure with the compressor running is @28 to 30 now and the car cools to ~40 degrees, albeit slowly. This is unlike yesterday, when the AC cooled rapidly to 38 degree - most likely related to the leak. Hopefully this will last me several months before crapping out. Eventual goal is to get a new drier, hoses and replace all o-rings.

 

Now my question:

Even with the R12 system, my idle would not increase when the AC was turned on. It is the same now - in fact the engine idle was set to ~750 rpm, it bogs a bit with the AC on. So I played around to see what the matter was. There is a vaccuum switch on the passenger strut tower with the AC relays. This switch has 2 ports, top and bottom. Can anyone tell me which port is for the hose from the firewall and which one connects to the AC related diaphragm gizmo on the carb? The gizmo on the carb has a lazy L rod sticking out to the front - this rod was not engaging the throttle arm at all. With some force I could move the rod in and it would spring back, but the vacuum on the hose is quite weak and with the AC on, I could not see the rod moving in. So I greased the rod a bit to free it up, no luck. I pushed the throttle back manually and was able to turn the lazy L thing to engage the throttle arm. I adjusted the idle up to 1000 rpm, to reduce the bogging of the engine. I am sure there is a way to adjust the AC gizmo on the carb. It has an adjustment screw on the back side.

 

The bogging of the engine is not the only problem, with everything on, the dash voltmeter reads a measly 8 to 10 volts and I am sure this is not good. With or without the AC, this has been a problem. The best I have had the dash voltmeter read is ~11.5 volts.

 

Does anyone have the instructions for a dealer installed AC set-up?

 

Appreciate it.

aba4430

Share this post


Link to post
Share on other sites

hey aba, cant help u with any of ur thread,but wanted to tell u when u need or get ready for hoses go to goodyear. thats where i went and they made me all new hoses for my 85 brat and pretty reasonable too. good luck

Share this post


Link to post
Share on other sites

Thanks for the lead on the hoses. Is this any Goodyear tire place I need to go to and speak about replacement hoses?

 

Regards,

aba4430

Share this post


Link to post
Share on other sites

not positive on that aba, down here we have goodyr. stores that specialize in just about anything rubber,but i know this it has to be a goodyr store and not just a place that sells tires. hope it helps ya. bb

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×