Jump to content
Ultimate Subaru Message Board
cyama167

92 loyale a/c compressor always runs

Recommended Posts

I'm working on a 92 loyale 4wd wagon AT and AC.  When I select anything on the panel the AC compressor runs and cycles on and off while its running down the road. I can tell because it pulls on the engine when the compressor engages.  I have seen defrost cycles run the AC compressor on some cars, but not the heater. Is this designed into these cars?  This is the 2nd panel I have changed on the car because the vacuum valves inside the panel dried up, but both have acted the same way with respect to the AC running. Any suggestions or help is appreciated! 

 

Share this post


Link to post
Share on other sites

Compressor cycling is normal.  BUT  It should only run in defrost and AC modes.  It should not run in any other mode.

Having a FSM schematic should help you.

 

I think the switch that actuates the electric part of controlling the compressor is a micro switch that is mounted on the heater box.  It gets activated by linkage moved by the vacuum motors when AC OR defrost is selected.

Share this post


Link to post
Share on other sites

Thanks Dave! Where can I find the FSM schematic?  Do you know if this micro switch failure is a common problem? I was lucky enough to get into 4 or 5 loyales at the local pick and pull last month, so I can take additional parts if necessary.

Share this post


Link to post
Share on other sites

There might be a link for the schematics somewhere on the forum. Or maybe the whole manual? Am am not sure, since I've had them since I bought my first GL.

 

I have not seen this as a common failure, or read about it here often, if ever.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×