Jump to content
Ultimate Subaru Message Board

Recommended Posts

I bought a 97 legacy L, 2.2, auto, 270k. Motor runs , trans has torque bind. Tcu codes show duty c solenoid. I wanted to drive it to see if it was worth fixing the solenoid so I disconnected the rear driveshaft. Torque bind went away  but the u-joint is clunking against the differential flange.  Is there another connection to the differential behind that bracket it sits in? Do I need to remove the u-joint and if so could you tell me how? I'm a carpenter, not a mechanic. If not for the info on this forum I would never have gotten this far

Share this post


Link to post
Share on other sites

Unbolt the center flange behind the carrier bearing and remove the whole rear half of the driveshaft. Leave the front section in place.

Share this post


Link to post
Share on other sites

I see you got the codes but did you try the FWD fuse under the hood to confirm it's the Duty C? If it works and the TB goes away, it's NOT the Duty C it's the transfer clutches (mechanical). If it makes no diff, then it's the Duty C and electrical.

 

Also, have you done the 3 Drains > Refills>>Drives routine to clean out the ATF?

 

With 270K and living in FL, I'd probably just drive it w/the FWD fuse installed if it works? 

Share this post


Link to post
Share on other sites

the fuse was in the holder when I got it, apparently having no effect, ( no fwd light on dash.) I did the atf change and added some trans ex for good measure but no effect on binding. Changed rear diff oil whileunder the car.   Thanks, fairtax for the tip on taking the whole thing out. I may eventually do the duty C if I can find a good how-to video on youtube.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×