Jump to content

Recommended Posts

Hey Guys looking for a little direction and were to go from here. I have done a lot of work to this car and need to get it through inspection.

 This 1999 legacy had a engine swap before I bought it and now has a 2.2. The previous owner did not have emissions so when I first got it I had to change the intake and get one with a EGR. This has all been done the car runs but has a miss on cylinder 3 & 4 and a EGR flow malfunction.Not sure were to go from here I put a timing light on spark plug wire 3 &4 and both are showing a erratic flash indicating a miss could the coil be getting a bad signal I swapped coils and the problem was still present.

 

 

Share this post


Link to post
Share on other sites

Did it run fine with the other intake on it before you changed it

Share this post


Link to post
Share on other sites

The car always seem to have a miss I don't think it was caused by the intake swap.

Share this post


Link to post
Share on other sites

The car has new plugs wires and i have swaped the coil the miss is always present

Share this post


Link to post
Share on other sites

Cylinder #1 145

Cylinder #2 145

Cylinder #3 150

Cylinder #4 135

 

These were done on a cold engine and removed only the plug from the cylinder that was being checked.

 

The car seems to run without a miss at times. Missing is most present at low RPMs under load.

Share this post


Link to post
Share on other sites

Anyone else have any ideas on why this engine is missing ???? Are those compression numbers close to were a 2.2 should be?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×