Jump to content
Ultimate Subaru Message Board

Recommended Posts

Car flashed a bunch of icons returning home from dinner last night.  CEL/cruise/the letter "S"/some icon that looks like a car with 2 squiggly lines.  Used a code reader this morning and the reader gets me as far has "Err" which I assume is error.  

 

Checked the same reader in my 95 and it worked as designed. 

 

What am I doing wrong or do I need a newer code reader. the one I have is at least 10 years old.  

 

Back to the 08.  Went to change the shift mode (car has 3 different settings) and no-go.  Remained in the "sport" mode.   

 

Share this post


Link to post
Share on other sites

the 'squiggly' lines is usually traction control - Owner's Manual will confirm.

 

That generally does indicate an issue w/the Transmission-side. Simple 'CEL'  code readers would not likely read those anyway.

 

2008 is probably CANBUS...although I thought the OBD2 scanners still worked....may b not so much?

 

Search online for a CAN BUS reader or see if you can find the manual for yours to verify.

 

No sure  about 'what' would cause your issue....

 

Did you drive thru a snowstorm? A big puddle? Go 'muddin''? Just wondering if something got on one of the wheel ABS sensors, etc.

 

I'd try the battery reset....Of course, this doesn't 'fix' anything...The cause of the issue will come back. but depending on how quickly it comes back may give you a clue....but NOTE that you'll lose your radio presets and you MUST know how to re-program your keyless entry / fobs BEFORE doing this. 

Share this post


Link to post
Share on other sites

Not so sure about the reprogramming of remotes. Have changed battery and never had to reprogram the remotes on my 08.

I use a cheapo scanner to scan and reset my 05 and 08 like the $15 one linked below:

LINK

It plugs into the terminal and doesn't require a computer or smart phone. Simple to use.

I have gotten error codes when I turned the key to the on position Before attaching the reader.

Correct sequence: key off/attach scanner tool/key to on position/hit scan button

Share this post


Link to post
Share on other sites

Traction control and cruise are disabled when the CEL comes on, so those lights turn on as well.

 

Sounds like you just need a newer code reader. Look into the Torque app if you have a non-iPhone.

  • Like 1

Share this post


Link to post
Share on other sites

Ordered new code reader and from the photo noticed the plug has 16 pins whereas my old reader has far fewer.  Will know something next week when the new one gets here. 

Edited by john in KY

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×