Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
George Griggs

82 Brat won't start

Recommended Posts

My 82 Brat won't start. It isn't getting a spark to the plugs. I tested the ignition module and it has power to it, so I replaced the module. At the same time I ordered a new distributor cap and rotor. The new distributor cap and rotor wouldn't fit, so i used the old ones after scraping the corrosion off the contact surfaces.  The car started right up. I killed it, came back 30 min later and drove it 17 miles to town. Got gas, and started back to my house. Made a stop on the way for about 15 minutes and tried to start the car. It wouldn't start. Checked again and no spark. Checked the ignition module and it was getting power. Figured the ignition module had gone out again since I just bought a cheap one on ebay. 


Called my local parts house and ordered a Denso ignition module, coil (it was only $12 so what the heck the old one was an Accel) distributor cap, and rotor. Replaced the ignition module, and coil, but again the distributor cap and rotor were not the correct ones. Tried to start the car, but this time it still failed to start. Removed a plug wire and grounded it, no spark. I'm a bit stumped.


I would appreciate any suggestions as to possible solution, and any ideas as to why I seem unable to get the correct cap and rotor? Did they make more than one, or is it possible someone substituted and different distributor?



Share this post

Link to post
Share on other sites

Your 82 Brat came with a Hitachi distributor

.It sounds like someone swapped in a 2wd Nippondenso.That is why you getting the wrong parts.


Generaly speaking,most module failures are a result of mismatched coils,overcharging issues or very bad/loose

plug or coil wires.


I think the Hitachis are a little more robust than the Nippondensos,but,they fail too.

Share this post

Link to post
Share on other sites

Ok, so I picked up the correct distributor cap, and rotor (Thanks Naru). While I was at it I also purchased a new set of plug wires. Installed them all, and to my dismay still no spark!


Again I checked voltages, all was well. Left off the distributor cap and watched to make sure the rotor was turning (it was), and just to make sure I cleaned and polished the distributor plate and the brass standoffs below the new and third ignition module.


I also held a small screwdriver to the magnetic pickup that mounts below the rotor. While I could feel a slight attraction to the screwdriver blade it was quite weak. In fact unless I touched the blade to the magnetic and pulled it back there basically wasn't an attraction.  Does anyone know how strong the pickup should be? Are they available?


I also checked the fuse labeled "ECM", it too was good.


Anybody have any more ideas of what to look for? I'm rapidly becoming stumped!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this