Jump to content
Ultimate Subaru Message Board
bstone

P0335 Crankshaft Position Sensor A Circuit Malfunction

Recommended Posts

The CEL ie because the ECU is getting the starter signal, but the starter isn't turning. Thus the ECU assumes the crank sensor must be bad and throws a code. The crank sensor is not bad nor has it ever been bad. You are troubleshooting without understanding how any of this works.

 

 

+1.  sometimes referred to as a "ghost code".  Happens when ECU sees the start signal but the engine does not turn so no Crank sensor pulse.

 

GDs relay mod is great for helping out when the Ig switch contacts/circuit get old.  I might suggest to use minimum 14 gauge or 12 gauge wire for ground and "30" pin.  And add a 25 amp fuse to that wire from "starter post Batt +"  to pin 30.  At a minimum a 2" length of 14 gauge fusible link wire should be used.  

 

You don't want to add any unfused direct to battery + wires to the car.  Fire hazard.

  • Like 1

Share this post


Link to post
Share on other sites

OK I just wired up the relay and so far it’s working. Why didn’t anyone tell me it was pretty easy to do? The relay didn’t have any diagram so I found one which was previously linked but the numbers weren’t exactly the same so I swapped around until the solenoid would engage. I made sure to use a 30A inline fuse connected to the 30 spade.

The real test will come tomorrow after it’s sat overnight in the cold. That’s when I have the most difficulty in starting.

Edited by bstone

Share this post


Link to post
Share on other sites

It's the starter. It wouldn't start with the relay but a friend banged on the starter as I turned the key and that caused the starter to engage. Seems I got a crappy starter. Do you all think copper contact replacement will help or this needs a new quality starter?

Share this post


Link to post
Share on other sites

Double check the ground cable connection.

 

But if that is good I would get the Denso starter.

Share this post


Link to post
Share on other sites

1. verify wiring as said

 

2. personally i'd get a used OEM Subaru starter and replace the contacts.  they're a dime a dozen. 

Share this post


Link to post
Share on other sites

Double check the ground cable connection.

 

But if that is good I would get the Denso starter.

I added an additional grounding cable to the starter. Also from the engine to chassis and another from alternator to battery. No love.

 

Is Denso the consensus here? Crazy thing is since my buddy hit it while I turned the key it's been totally reliable.

Share this post


Link to post
Share on other sites

1. verify wiring as said

 

2. personally i'd get a used OEM Subaru starter and replace the contacts.  they're a dime a dozen. 

I'll thriple check the wiring.

 

2. I did that for the last starter-used OEM Subaru and replaced the plunger and contacts but it didn't help with the intermittent failure to start.

Share this post


Link to post
Share on other sites

2. I did that for the last starter-used OEM Subaru and replaced the plunger and contacts but it didn't help with the intermittent failure to start.

 

Right - but the first time you removed a perfectly fine starter and installed a bad one (presumably you said it stuck - check all the relay/wiring/ground).  First time was wiring issues which again presumably are resolved - so now there's a sticking/bad starter.

 

I wouldn't want the liability of getting stranded somewhere given how many aftermarket starters fail.  Some people might be okay taking a high percentage risk, if that's you then yeah just ignore it and see what happens. 

 

A new starter sticking and freeing is common.  Saw it last year. Fine first month or 3, stuck, then progressively suck more and failed in a few months.  He got his Money back and I installed an OEM one for him.  Not uncommon at all, but you could conceivably get lucky but my time isn't worth it on components like starters, fuel pumps, and alternators which strand the vehicle. 

Share this post


Link to post
Share on other sites

Right - but the first time you removed a perfectly fine starter and installed a bad one (presumably you said it stuck - check all the relay/wiring/ground).  First time was wiring issues which again presumably are resolved - so now there's a sticking/bad starter.

 

I wouldn't want the liability of getting stranded somewhere given how many aftermarket starters fail.  Some people might be okay taking a high percentage risk, if that's you then yeah just ignore it and see what happens. 

 

A new starter sticking and freeing is common.  Saw it last year. Fine first month or 3, stuck, then progressively suck more and failed in a few months.  He got his Money back and I installed an OEM one for him.  Not uncommon at all, but you could conceivably get lucky but my time isn't worth it on components like starters, fuel pumps, and alternators which strand the vehicle. 

Last time I bought a used OEM starter which worked for several months but then the click-no-crank happened so I put in the new contacts and plunger but the problem of click-no-crank persisted. I then replaced it with another used OEM starter (the current one) which was fine for a few months and then the problem of click-no-crank occurred. I thought the current starter was new from Advance but I was wrong as it's definitely used OEM. Sorry for that confusion! I'm open to replacing the contacts and plunger again since it's cheap and easy but I'm curious if you think that will help the current click-no-crank or if I should go with a Denso starter.

 

Also, to ensure I have the crank relay set up correctly so I take a voltmeter and probe the wire going from the relay to the starter spade connector and the other probe from the relay to the battery? Or can I just probe the 30A fuse? What is a correct voltage reading (I'm assuming 12V or abouts but want to make sure). Does it matter if the key is on or does the engine have to be actively cranking?

Edited by bstone

Share this post


Link to post
Share on other sites

have you tested the ignition and voltages yet? i'd start there.

 

i'd think the starter needs engine turning to see the signal wire and power feed. but i'm good at mis-interpreting/mis-speaking electrical stuff with typing....

 

3 failed OEM starters with new contacts is an impossibility unless they're being dredged from the bottom of the ocean.

take it off and test it - auto parts stores test starters or you can just do it on the ground.

have any of the other ones still around - go test them too.

 

of those 3 starters - there's a misdiagnosis, information, installation, or some other issue. maybe this current *one* has a failure since of course it's a mechanical part and anything can fail. but there's so much poor history in this repair that i would not condemn another starter until all voltages and ignition operation are verified and the starter is thoroughly and properly tested.

Edited by idosubaru

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×