Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
yournmhr

Gas smell in a '79 Brat with EA81 conversion.

Recommended Posts

I purchased a 1979 Brat with an EA81 conversion back in October '17 and need some help with a gas smell.  I mostly detect the smell on the freeway, but also under hard (relative) acceleration.  I've gone through the process of tuning the carb as best I can without a functioning tac (would love some help getting that working as well...), but the gas smell persists.  I replaced plugs and wires and changed the oil and filter after the carb tuning, thinking that the carb may have been running rich and contaminated the engine oil with gasoline.  I'm fairly mechanically inclined, but have very little knowledge of carburetors. Also, trying to wade through the mess of someone else's conversion is getting tiresome.  

 

Any help at all would be greatly appreciated!

Share this post


Link to post
Share on other sites

they sell pressure regulators, Mr. Gasket has one for about $30 at any autoparts store, i put a GM pump with a regulator on mine.

 

also perhaps a pinhole leak due to age of the hose when things warm up? reminds me of my coolant leak that woudn't leak unless i was on the highway, turned out to be the radiator after a few days of confusion.

Share this post


Link to post
Share on other sites

Thanks for the suggestions, folks!  I did check the filler pipe and wasn't able to see any leaks there, but I might just replace it anyway as the rubber did seem a little weather checked.  I honestly don't know if there is a regulator on the fuel line, but I will take some pictures and upload them.  Maybe someone here will be able to spot a regulator if there is one.  I did my best to trace the fuel lines from the tank, but it's pretty hard to follow them all the way back and I could find any leaks where I was able to trace them.  Maybe I just need to start replacing lines I can follow, starting from the engine.  The heat thing makes sense to me, as it's only recently been a problem... 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×