Jump to content
Ultimate Subaru Message Board

Recommended Posts

Under the intake there is the coolant crossover as well as the two heater exchange tubes.

 

Firstly , I’ve got the intake off and am resealing the engine. Should I bother with that crossover duct ? Looks nice and tight and dry. Are there gaskets under it??

 

Be right back

Share this post


Link to post
Share on other sites

Secondly , those two tubes for the heater box. Anyone ever have those get pinholes from rust?

The engine I got had some leaves and grime built up around it. I inspected it , sanded and painted it.

 

Normally I’d just use my existing engine’s heater tubes. But I really need to have this engine buttoned up and ready to quick swap. I won’t have time for repairs like this. I don’t have a garage and I’m borrowing space at a friend's and it’s got to be a one day deal to do the engine swap.

Share this post


Link to post
Share on other sites

And lastly , when I removed the intake it sure looked like there were no gaskets under it.

 

Was I just a little blind and need to look closer?

 

Thanks !

Share this post


Link to post
Share on other sites

Intake definitely has gaskets.

 

Coolant crossover pipe is worth removing to replace the two O rings under it. Make sure they're genuine Subaru items ;)

 

Cheers

 

Bennie

Share this post


Link to post
Share on other sites

Intake definitely has gaskets.

 

Coolant crossover pipe is worth removing to replace the two O rings under it. Make sure they're genuine Subaru items ;)

 

Cheers

 

Bennie

 

I use appropriate sized Buna rubber O-rings for them.  should have large enough diameter that you have to slightly roll them into position tight inside the lip of the seat.

 

For turbo cars I use the subaru Orange rubber o-rings that are normally for the case half water tube.

 

Definately replace the o-rings, and best to pull that heater return tube.  If you unclamp the elbow hose at the water pump, you can bring that whole pipe up and out and inspect and paint while you've got the crossover pipe removed.

Share this post


Link to post
Share on other sites

Yes , already removed , sanded , and painted the tubes after inspecting them.

 

The large tube which sits lowest and gathers more debris around it , is pitted. I’m hoping my painting it repels enough moisture that it doesn’t rot any further. Once it’s installed it’ll never get dirty like it the way it came to me.

 

Thanks for the advice. Always always always Subaru seals and gaskets.

 

For those keeping score I’ve got the rear side done - main , cam cap seal , and separator plate.

Yes , I’ll get the O ring for the passenger side rear cam.

 

Took the water pump off and the impeller was awful rusty looking so I’m going with the one from my existing engine , or a new one I have laying around.

 

Thanks again. I’m sure Subafreak appreciates my not texting him with all the questions. Lol

Share this post


Link to post
Share on other sites

WOW ! Man am I glad you guys told me to get those O rings!!!

 

They would have failed sooner than later I’d guess. Easy enough on wallet , time , and bolts came out without stripping - going back n forth at first cracks saves threads.

 

Moving along well for working in small chunks of time. Just need a fresh water pump and timing.

 

Thanks again! Cheers!

Share this post


Link to post
Share on other sites

You can get the cam support / distributor cover o-rings in Viton if you buy them from McMaster. That's what I used to do. The cam seals you can get from Subaru and they are superseded to the Viton one's anyway. 

 

GD

Share this post


Link to post
Share on other sites

funny, but I am in the midst of basically the same job on my 2002 Forester with EJ251.. had holes in the heater hose pipes, and possibly a failed o-ring for the crossover.. so yeah, they do rust through. hopefully you caught it early enough.

 

and yes, there are most definitely gaskets for the intake.

  • Like 1

Share this post


Link to post
Share on other sites

Yeah the O rings looked old school black - not the blue Viton. They also appeared slightly oversized but you can just manage to set them into their recesses and get the crossover back on before the popped.

 

And yes , I sanded and painted that large tube which sits too close to the block.

 

Now my paranoia is the my oil pump will chump out on me down the line because I gooped up that area of the pump that the O ring goes up against. I meant to leave that area bare and just seal the perimeter of the pump and around the bolt holes. But I got too happy and didn’t think about it until after I’d bolted up the pump.

 

Subaru tech advises it’ll probably be fine but I’ll carry the paranoia for a while.

I’m tempted to just take the pump off and inspect before I proceed with setting the timing back on.

Share this post


Link to post
Share on other sites

The piece of mind knowing the job is done right will be worth the extra effort to remove the oil pump now

  • Like 1

Share this post


Link to post
Share on other sites

Ok , I guess I had that wrong. I guess all those blueish O rings I’ve used were of lesser quality ? Never had an issue. My dealer parts guy is great and an older guy so I trust him. Talking about the oil pump O ring.

 

So I’ll take that step backwards today and check the pump. Waggggghhhh :(

 

On the near horizon I’ll be taking the show over to a friends place and place the engine on a stand so I can comfortably get the oil Pan resealed.

 

I’ve seen and even have somewhere an oil pan gasket. Many folks say they don’t exist and only use Fuji-bond , etc.

 

What’s your method ?

Share this post


Link to post
Share on other sites

Ok , I guess I had that wrong. I guess all those blueish O rings I’ve used were of lesser quality ? Never had an issue. My dealer parts guy is great and an older guy so I trust him. Talking about the oil pump O ring.

 

So I’ll take that step backwards today and check the pump. Waggggghhhh :(

 

On the near horizon I’ll be taking the show over to a friends place and place the engine on a stand so I can comfortably get the oil Pan resealed.

 

I’ve seen and even have somewhere an oil pan gasket. Many folks say they don’t exist and only use Fuji-bond , etc.

 

What’s your method ?

 

lots of OE subaru O-rings that come in contact with oil are blue. Just a high quality rubber to my knowledge.

 

Including the reinforced one you will want to get from the dealer for the oil pump.  it's blue rubber, and it has a "skirt" in the interior diameter.

 

DO NOT use a gasket on the oil pan.  Just use good sealant.  I use "the RIght Stuff" brand.  in your rusty area it might be worth buying a new oil pan to install, rather than rehabing and cleaning the old rusty one which can be a PITA.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks. I’ll just use the right stuff. I’ve got one bottle going and another I haven’t opened yet.

 

I see that new pans aren’t too pricey. I’ve got a little time so I’ll drop the existing pan and decide.

 

Somewhere in all my crap might be an NOS pan. I know I had one once but might have used it already.

Share this post


Link to post
Share on other sites

The Three-Bond 1217H is what we use. Nissan has it cheapest.

 

The blue o-rings they sold you for the oil pump are likely something the dealer has sourced in bulk from outside of the Subaru parts channels. They will work fine I'm sure. But the proper case half/oil pump o-ring is Buna-N with a flange on the ID.

 

GD

Share this post


Link to post
Share on other sites

Good to know.

 

Took the oil pump off and the O ring had gotten a kink in it but was in place. The previous pump seal had the same “D” shape deformation in its O ring , and mine had done the same. Removed all the goop and started over. Happy now.

 

Water pump on - my one weak llink here using a Chinese pump - sorry , but it was sitting on my shelf paid for and I can always suck it up if it fails early as we all expect.

  • Like 1

Share this post


Link to post
Share on other sites

Would be nice if my local Nissan dealer wasn’t a douche. Terrible people on the phone. Jackass says they don’t sell it. I’ve got a day to work with. But yes I’ll get some instead of Right Stuff.

Share this post


Link to post
Share on other sites

Would be nice if my local Nissan dealer wasn’t a douche. Terrible people on the phone. Jackass says they don’t sell it. I’ve got a day to work with. But yes I’ll get some instead of Right Stuff.

 

That's ridiculous - must be something in the water out on the east coast. People here are glad to help - we buy it by the case (6 tubes). It's about $110 for a case from Nissan. It's also sold all over the net. 

 

GD

Share this post


Link to post
Share on other sites

Picture test.Jvq6r2.jpg

Nothing special , sorry.

That seems better ;)

 

Use the direct link and the codes for posting an image: img direct link /img <- put square open and close brackets around the two img codes and your image will be displayed ;)

 

Cheers

 

Bennie

Share this post


Link to post
Share on other sites

Bennie , I’ll do what I can. Working from a phone only these days. But thanks.

 

Going to do that pan later today , but only if I have a good sealant. If I can’t score the Three Bond you folks think I should use RTV or something else ? Or calm myself down and wait until my internet ordered tube comes in ?

Share this post


Link to post
Share on other sites

Bennie , I’ll do what I can. Working from a phone only these days. But thanks.

 

Going to do that pan later today , but only if I have a good sealant. If I can’t score the Three Bond you folks think I should use RTV or something else ? Or calm myself down and wait until my internet ordered tube comes in ?

 

"the RIght Stuff" is what I use for nearly everything.

 

The regular permatex gray and black tend to not stick/seal as well long term.  And it gets hard and burnt/brittle after about 5 years.  "the Right Stuff"  stays well stuck and soft and rubbery for years and years.  I use it for trim adhesive as well.

 

It''s friggin awesome.

 

One tip I will offer.

 

Wipe off excess that squeezes out while it's still soft.  If you leave big blobs of it to dry it can get tugged on accidentally when wiping off oil at filter changes.  And because it's so tough and rubbery, it's possible to actually pull/stretch it out of seams. 

 

So wipe it off so only thin smears remain and then it can't get pulled out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×