Jump to content
Ultimate Subaru Message Board

Recommended Posts

My 98 impreza L wagon heat cuts off when I have it blowing full blast, when I turn the nob to turn it off and then on again it comes back on. But after a little while it will shut back off. Anyone have any tips on what I can do? Thanks!

Share this post


Link to post
Share on other sites

the fan cuts off? or, does the fan continue blowing but the temperature is not hot?

 

(why the heater in July ?)

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
1 minute ago, 1 Lucky Texan said:

the fan cuts off? or, does the fan continue blowing but the temperature is not hot?

 

(why the heater in July ?)

I am trying to fix it if I can for the fall/winter coming up lol. The fan just cuts out all together after a time and wont blow, like goes silent all together. But if I turn it off and then back on it comes back on for a time.

Share this post


Link to post
Share on other sites

There is a resistor pack in the air box ducting below the passenger glove box. 

It's most likely going open, no voltage to the fan.  Then the circuit closes providing power again.  Easy change 2 screws and a plug.

Share this post


Link to post
Share on other sites
1 hour ago, lmdew said:

There is a resistor pack in the air box ducting below the passenger glove box. 

It's most likely going open, no voltage to the fan.  Then the circuit closes providing power again.  Easy change 2 screws and a plug.

What exactly am i changing ? I know where it’s at, I’ve actually taken the fan apart before to clean the unit out to see if it helped . 

Share this post


Link to post
Share on other sites

The resistor pack is about an 1" square and about 2" long.  There is a electrical connector and 2 screws that you will see on the air ducting under the glove box.  Remove the connector and the screws pull it out.  Put the new one in.

The link shows a nice picture on amazon.

https://www.amazon.com/Wells-JA1230-Blower-Motor-Resistor/dp/B000EQO07O/ref=sr_1_3?ie=UTF8&qid=1532083883&sr=8-3&keywords=Subaru+Impreza+fan+resistor

Share this post


Link to post
Share on other sites

Yep, I missed he was on High Speed.

I have some spare fans.  $20 shipped

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×