Jump to content

Recommended Posts

95 Legacy 2.2L

The tick honestly sounds like what ive heard in videos as lifter/valve tick... But it doesnt do it until warmup, which is what most experience(i think?), but for me it does it only after it has warmed up for a period of 15 or so minutes of idle, and is not noticable when driving... as in i think it only does it when idle. 
no CEL, using 10w30 oil. 

Share this post


Link to post
Share on other sites

hydraulic lifters?

I've read some folks have used Marvel Mystery Oil or some other additives to help with lifter tick.

rod knock is quite loud and gets very aggressive at higher RPMs, some youtube videos demonstrate it.

  • Like 1

Share this post


Link to post
Share on other sites

Yeah, the sound is consistent with what ive heard as lifter tick, it just its habits seem opposite of what most ppl say theres does... ill try an oil change and maybe some MMO here soon. im do for an oil change within a couple hundred miles :)

Share this post


Link to post
Share on other sites

maybe low oil pressure? i seem to recall others mentioning tightening the screws on the back of the oil pump when doing a timing service.. if they are loose, you could be losing a little pressure, but it gets made up for when rpms are higher.

fwiw, the only time my 95 ticked was when oil was a little low, or it was due for an oil change.

  • Like 2

Share this post


Link to post
Share on other sites
5 hours ago, heartless said:

maybe low oil pressure? i seem to recall others mentioning tightening the screws on the back of the oil pump when doing a timing service.. if they are loose, you could be losing a little pressure, but it gets made up for when rpms are higher.

fwiw, the only time my 95 ticked was when oil was a little low, or it was due for an oil change.

that is a good point, honestly sounds pretty spot on considering as the car warms up, the oil becomes more viscous and doesnt have as much pressure as cold thick oil.

Share this post


Link to post
Share on other sites

My EJ22 has lifter tick when the oil is low. It’s like a built in indicator! 

Lifter tick is very different to knock in sound. Tick is a higher pitched frequency than that of knock which is a much lower tone sound. And knock from a dead/dying bearing sounds like it’s deep in the engine too (which it is). 

Cheers 

Bennie

Share this post


Link to post
Share on other sites

changed oil today, tick is still there, although more intermittently...
I will do MMO next, but im starting to lean on the screws on the oil pump as i have a small drip coming from bottom of the timing belt cover, creating a lower pressure... Driving and performance is otherwise unaffected...
Sound is towards the back of the right side head, facing the car.

Share this post


Link to post
Share on other sites

If the screws on the oil pump are loose they leak internally. The drop you’re seeing is probably the crank seal leaking. 

So LHS bank is making the noise. With the use of a stethoscope, you should be able to isolate the noise to the top end or the bottom end. 

Cheers 

Bennie

Share this post


Link to post
Share on other sites

agree the leak is most likely from bad seals - either crank or cam. Those should be (should have been) replaced when doing a timing service.

Share this post


Link to post
Share on other sites
13 hours ago, el_freddo said:

If the screws on the oil pump are loose they leak internally. The drop you’re seeing is probably the crank seal leaking. 

So LHS bank is making the noise. With the use of a stethoscope, you should be able to isolate the noise to the top end or the bottom end. 

Cheers 

Bennie

No stethoscope atm but i can say for sure i hear it more in the passenger Wheel Well than the top side

Edited by Jadu108

Share this post


Link to post
Share on other sites
14 hours ago, GeneralDisorder said:

Replace the lifter o-rings. 

GD

is this something that would have been done part of a valve job(or should have been). My friend who gave me the car had a valve job done within the last 30-40k, maybe more like 20k ago, about 2 yrs or so

Share this post


Link to post
Share on other sites

Alright. I will probably delay doing this for awhile, perhaps when i decide to do timing or something... The tick has quieted itself a bit and is less frequent so im not going to be concerned about it further.
Thanks for the input guys... 
If i do this in the near future I will update what i did and if it solved the issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×