Jump to content

Recommended Posts

Hello everyone, new to the forum. I have searched around a bit but could not find the info I was looking for. I have a 1990 loyale that hasn't run in quite a while. Over that time rabbits had rotten under the hood and eaten a bit of its wiring. 

I recently got it started and have replaced most of the eaten wires. However all 4 of the throttle position senor wires connecting to the harness are gone.

Would anyone be able to get a picture of the orientation of those wires into the tps? I have been able to find 3 pin versions all over but not the 4 pin which I believe is a later model part. 

Thank you for your time.

 

Share this post


Link to post
Share on other sites

You have four wires you can see remains of ?!

The early EA82 MPFi used only two as it was TP Switch

The hotwire maf ones went to three.

Even my modern after market race TPSensor on mine is still only three wires

SPFi yours??

Share this post


Link to post
Share on other sites

I can see the remaining wires coming from the firewall but everything on the tps is gone except the metal connectors. 

It is a SPFI. Even when I go to the parts store they can only find the 3 pin sensor. But from what I can see this one was factory wired for the 4 pin it's got.

My Chilton shows the tps as being for a 2.2ltr. Mpfi. 

Share this post


Link to post
Share on other sites

I got it wired up. It runs a bit better but still boggs down when the throttle is applied. I'm sure I've got other issues to work out tho. Thanks for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×