Jump to content
Faraim91

Retro fit power steering 82 GL

Recommended Posts

reversed power steering lines?
 

I upgraded my steering in my 82 Subaru gl to power steering. I bought an 82 rebuilt power rack and using a wrx power steering pump. I used AN6 lines for the high pressure and return line, but I wonder if I switch the 2 lines since I blew out the seals in the rack. I connected the M14 port (Front port) to the high pressure side (pump) and the M16 port (rear port) to the return line (tank). Is this correct? I bought a new reman rack, but wanted to make sure I had hooked up correctly.

BTW, if anyone is interested in some pics, I have an EJ205 rotated turbo (Garrett 3076 gen 2) in my 82 Gl with wrx suspension and brakes on all four corners. Took it around the block for the first time just a few days ago. All went well, minus the power steering.

Thanks for the help.

Edited by Faraim91

Share this post


Link to post
Share on other sites

That WRX pump might put out too much pressure for the original rack.  Did you research the specs on the two pumps before selecting, installing and plumbing the WRX unit?

Share this post


Link to post
Share on other sites

That could be the problem as well, but I used a wrx pump on an outback rack previously without issues, I didn’t think the wrx are higher pressure pumps than the normal aspirated motor ones. Are people using EJ pumps with EA81 racks? I thought I read that people did in another forum here.

Does that mean the lines were connected correctly than?

Share this post


Link to post
Share on other sites

I'm thinking it wouldn't work at all with the lines swapped.

 

It is typical of hydraulic systems to have the high pressure side use a smaller pipe / tube / hose diameter than the suction / return side.

Share this post


Link to post
Share on other sites

I don’t know if it ever worked since it was dumping fluid from the driver side seal right after I started the engine. 

Maybe I had a faulty rack? 

Share this post


Link to post
Share on other sites

I doubt it was the pump doing it. I know of several EJ power steering pumps operating MY/EA81 power steering racks without issues. 

Dis you run this rack without leaks previously? 

Cheers 

Bennie

Share this post


Link to post
Share on other sites

No, I bought the car not running and did the EJ swap right away. The new rack and pinion didn’t have any paperwork with it, so I wasn’t sure if the high pressure side was the smaller port like the EJ, but hooked up that way anyway.I figured i had 50% change of getting it right. Now that the seals blew out on the driver side, I thought maybe it was hooked up backwards. I was hoping someone here could verify which line is the high pressure and the low pressure for me. Is the small port indeed the high pressure and the large port on the rack low pressure?

Thanks,

Gilles

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×