Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
JWX

lets talk idle speed

Recommended Posts

in my RX with the defrost on it runs 2k RPM, I think this is a bit high. what does yours idle at? and is there a way to lower it? I know it kicks in for the AC but I'm not running the AC right now and 2K it still seems a bit high even for the the AC.

Share this post


Link to post
Share on other sites

I've got mine ('87 RX) set at factory spec (600rpm I think), turning on the A/C (or defrost when the A/C compressor is cycling) will bump it up about 200 more. My AAV works fine on cold start, but there is a point about a minute after start when it will idle as high as 2500rpm, then it slowly proceeds to normal as it comes up to temp. I dont think there is any adjustment for the AAV, maybe I should put a restriction in the AAV line to the manifold, I'd like to keep it under 1500rpm. Drivability is good right off the coldest start so maybe I'll just let it be.

 

Sounds like your AAV may be holding open, have you checked the circiut and coil resistance? Try pinching off the line from the AAV to the manifold and see if the RPMs drop.

 

Gary

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×