Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
WJM

Fuel gremlin still not solved

Recommended Posts

Swapped fuel pump and relays and fuel filters.

 

STILL THERE.

 

Those who dont know...5 seconds after I WOT...the injectors or ignition cuts out for 1/4 of a second...a huge JOLT...and then, 5 seconds later if still on WOT...again.

 

Its got new cap, rotor, wires, plugs, and known good coil. Ive swapped MAFs, not ecu yet, fuel pump, filters, replays...ect.

 

any ideas?

Share this post


Link to post
Share on other sites

now that i read more..i think we did have this problem.

 

however....i'm not sure if we ever really found the root of the problem.

 

 

We replaced absolutely everything. I think the one thing that might have worked was the replacement of the ECU..

 

it was soo long ago i can't remember.

Share this post


Link to post
Share on other sites

Go find one in the wrecker....they can be had for like 30 or 40 bucks usually (around 50 CDN)

 

www.car-part.com is a good place...i haven't checked but i'm sure there are plenty.

 

any EA82T computer after 87 will work i believe.. just some had different brackets and crap.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×