Jump to content
Ultimate Subaru Message Board

Recommended Posts

Ok. Ive owned the Loyale for over a year. The fuel pump has always been quite noisy. A loud humming noise to be exact. i've put something like 14,000 miles on it with no problems. However, whenever i use the turn signals, i can hear the fuel pump pulsing in time with the turn signals. Any ideas? thanks...

Share this post


Link to post
Share on other sites

funny thing, ol jim wood's wagon was doing that today. not too noisy to worry about.

 

i had a dl that got loud after i ran it out of gas, but still worked fine

Share this post


Link to post
Share on other sites

ya, its not really the loudness of the fuel pump that worries me. It's the fact that i can hear the fuel pump whirring in time with the signals. i presume it is drawing power from the fuel pump. hmmm

Share this post


Link to post
Share on other sites

hah! mine does the same thing..pulses in time with the turnsignals and humms all the time...wouldnt be so bad if i had a stereo in there but dont yet :D you say check the fuel filter?

Share this post


Link to post
Share on other sites

ya, i was thinking somewhere along the lines of bad grounds. looks like ill be cleaning them up this week, weather permitting. mid 40's and rain.. its winter you say?

Share this post


Link to post
Share on other sites

not yet.. i cleaned a couple grounds, but no change. i can't really jump into it fully yet, as its pouring rain out. hopefully this wwkend i'll have the time and weather

Share this post


Link to post
Share on other sites

I know this thread is ancient but I think I have this exact problem. I originally thought it might have been alternator whine or something but this fits the picture to a T. It's quite a loud hum and drops in tone with the turn signals. It's done it since the day I bought my car. 1990 Loyale 5spd 4wd 235,xxxkm's.

 

Any solutions other then turning up the music?

Share this post


Link to post
Share on other sites

From what I've read on the board here,it's not an issue,really. More of an annoyance. I can't remember what was said that might cause it,thou. My Loyale does the same thing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×