Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
sregor13

Air Shocks and Gas Gauge on 94 Legacy Wagon LS

Recommended Posts

The 94 Legacy Wagon I just bought apparently is having trouble with the Air Shocks. The seller said those worked before the Crank Sensor went out ( A seperate issue and thread) It has been sitting for a While, and now the Air Shocks wont fire up. Also the Gas Guage is not working. Does it sound like thiis might be a Fuse? Thanks

Share this post


Link to post
Share on other sites
The 94 Legacy Wagon I just bought apparently is having trouble with the Air Shocks. The seller said those worked before the Crank Sensor went out ( A seperate issue and thread) It has been sitting for a While, and now the Air Shocks wont fire up. Also the Gas Guage is not working. Does it sound like thiis might be a Fuse? Thanks

 

I guess I will reply to my own thread if there are no objections- The Air Shock issue is causing my Subaru to bounce at the slighest bump. This bouncing is causing the car to be unable to drive. Leaving my friend stranded in Long Island. Also for some reason the car is not keeping idle. So driving down the interstate, he encounters a problem where if he lets off the Gas to slow down the idle drops and the car dies. Im desperate, Thanks

Share this post


Link to post
Share on other sites

Sounds like multiple problems occurring here. The shocks not working may well be a fuse or solenoid, but may also be a faulty compressor. Don't drive it any further, as it's riding on the bump-stops and will become quite damaged. Not sure about the idle problem, could be a number of things.:-\

 

Good luck.

 

 

I guess I will reply to my own thread if there are no objections- The Air Shock issue is causing my Subaru to bounce at the slighest bump. This bouncing is causing the car to be unable to drive. Leaving my friend stranded in Long Island. Also for some reason the car is not keeping idle. So driving down the interstate, he encounters a problem where if he lets off the Gas to slow down the idle drops and the car dies. Im desperate, Thanks

Share this post


Link to post
Share on other sites

In searching it looks as if the Speedometer Sensor may be tied to the Air Shock Sensor. I dont know where this sensor is? But that is half my problem. AS far as the Idle I have experienced it before in what was diagnosed a Injector 1. But I suppose there is probably an Idle Control Sensor as well. This car had not run for quite some time do to a Crank Sensor. That was replaced and the Car did start but then the Air Ride was not working. So thanks for replying. I appreciate any thoughts on this one becasue my buddy is stranded in Long Island.

Share this post


Link to post
Share on other sites

Sorry I don't have the wiring data for that car. I will say this, IMO, this guy ripped you off. Or maybe you shouldn't have bought a car with known problems. Sometmes, if the price is too right, you have to second guess it.

 

Make sure your friend checks all the fuses, maybe there is one blown.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×