Jump to content
Ultimate Subaru Message Board

Recommended Posts

Hey,

looking for a common solution. 87 gl wagon, dome light gets no power... Looking to see if this is common, and if so, whats the fix. I checked fuse 3 as the owners manual says... its good.. the grounds good... powers a no show... wires are plugged into the socket on the back(pulled it off the roof) any ideas, I dont want to rip up my headliner

Thanks

Share this post


Link to post
Share on other sites

run a new power wire. use a quick splice connector and hook it to the radio power wire or something else thats on the fuse box. pull off the plastic trim on the A pillar on the drivers side.

 

Now you are going to need to get a piece of seisemic wire (its stuff like bailing wire, but its a lil thicker. They use it to hang the guides for tile ceilings. Run that from hole in the head liner for the light, over towards the A pillar on the drivers side. This may take a lil time and patience to get the seisemic wire to the right spot to where it will stick out at the end of the headliner, but its worth it and will save you the hassle of wrecking or folding the headliner.

 

Once its to the A pillar, tape the wire to the seisemic wire. now pull the wire through.

Share this post


Link to post
Share on other sites

Thats a good idea... thanks.... Maybe I can just run it to the pillar and chek the wire from there to the light.... and reuse. Is the ground for the light just the roof under it(above)? I really didnt look...

Thanks

Share this post


Link to post
Share on other sites

I have heard of wire problems with screws and such at areas above the drivers and passengers head, also the map light area.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×