Jump to content
Ultimate Subaru Message Board

Recommended Posts

Hello,

 

I recently started having this strange problem. When I turn the ignition off on my 95 Impreza L, AWD the taillights and one of the parking lights stay on. They only go off if I take the fuse out in the fuse box. My brake lights work fine but at night when I need my tail lights I have to put the fuse back in. Would this have something to do with teh communication between the ignition and the lights when you turn the ignition the lights go off also. If anyone has had this similar problem I would greatly appreciate any insight into this problem.

Beau

Share this post


Link to post
Share on other sites

Have you checked the toggle switch on the top of the steering column? That's the "magic" parking light switch just in front of the dashboard.

Share this post


Link to post
Share on other sites

This is a classic noob problem. The little red "P" switch at the top of the steering column controls the running lights when the ignition is off because most everything electrical is primarily routed through the ignition circuit. If you can't start the car, yet it needs to be visible by the road, pop that little thing on. Good thing you came here before going to the dealer. They'll probably charge you some beaucoup bux just to tell you the little switch is on.

Share this post


Link to post
Share on other sites

thanks. I should have thought of that but you know how that goes. I never call the dealership. Only to ask what a part number is and they almost try to charge you for that (jk).

 

Beau

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×