Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
calebz

Question for the TD04 people

Recommended Posts

As many of you know, I am running a TD04 on a 9.0:1 EA82.

 

I had heard that the stock wastegate on the TD04 was set to 7-8 PSI

 

But for some reason I am only seeing 5-6.. No boost leaks that I can see/hear

 

Also, vacuum is right around 18 in/hg at idle

 

Does this sound normal or do I need to step up my search for leaks?

Share this post


Link to post
Share on other sites

If your exhaust is still the small diameter original exhaust it could limit you from building proper boost. Do you have a boost controller and are you using the stock ECU for a turbo EA82. How you have your turbo set up is really important. Please give more info on the setup you have.

Share this post


Link to post
Share on other sites

Current exhaust is stock WRX downpipe.. thats it

 

 

No boost controller on there right now. Operating strictly on the wastegate. Even the stock EA82 wastegate solenoid has been removed.

 

The 5-6 psi that its currently boosting to is nice and steady, no spikes or fluctuations. Will probably pop the MBC on there this evening to see what happens.

 

I am a little concerned about the vacuum levels as well.. After a little readin it seems that most people here are in the 20-22 in/hg range, whereas mine sits steadily at 18.. That could be a timing issue though. Will explore that later.

Share this post


Link to post
Share on other sites
Current exhaust is stock WRX downpipe.. thats it

 

Ah yeah, I remember that sound, pretty freakin tough sounding eh.....if not a little obnoxious.....

 

I have a GFB MBC in line but its turned all the way down. I boost to 7-8 psi just like you stated is stock wastegate setting....

 

Is the wastegate getting signal off the output of the turbo or somewhere else?

 

I can't comment on the vacuum deal as Delta cams really seem to through vacuum off....

 

 

garner

Share this post


Link to post
Share on other sites
...

I am a little concerned about the vacuum levels as well.. After a little readin it seems that most people here are in the 20-22 in/hg range, whereas mine sits steadily at 18.. That could be a timing issue though. Will explore that later.

I was thinking that the idle vacuum reading was rather low, too. I seem to remember 22-24 on the last car that I had a vacuum guage on. 18 in of Hg sounds like something you would see on a car with a lot of valve overlap (aftermarket cams?) or some other significant issue. Is the idle vacuum reading fairly steady, of does the needle bounce around or vary? What kind of max vacuum are you showing on overrun/engine braking?

Share this post


Link to post
Share on other sites
Ah yeah, I remember that sound, pretty freakin tough sounding eh.....if not a little obnoxious.....

Is the wastegate getting signal off the output of the turbo or somewhere else?

garner

 

Its a bit on the noisy side.. A bit obnoxious too:-p

 

Sorry, neglected to mention, the wastegate is getting signal straight from the turbo output. Boost is not fluttering or falling.. sticks right at 5-6 psi

 

I was thinking that the idle vacuum reading was rather low, too. I seem to remember 22-24 on the last car that I had a vacuum guage on. 18 in of Hg sounds like something you would see on a car with a lot of valve overlap (aftermarket cams?) or some other significant issue. Is the idle vacuum reading fairly steady, of does the needle bounce around or vary? What kind of max vacuum are you showing on overrun/engine braking?

 

No aftermarket cams. Idle vacuum is rock steady at 18 inches. Didn't really pay attention to what the max was. I know it was quite a bit higher. I will throw a guess out at 26 inches or so. Will have to drive it again and check.

Share this post


Link to post
Share on other sites

6 PSI sounds fine. I remember seeing 7ish on mine with just the wastegate.

 

18 sounds decent. Stock I used to pull 20ish, with the delta cams I have like... zero :lol: ... Ok, not that bad, but its pretty low.

Share this post


Link to post
Share on other sites
6 PSI sounds fine. I remember seeing 7ish on mine with just the wastegate.

 

 

Well, just for the hell of it I hooked up the MBC and turned it all the way down the where I could hear the ball rattling inside. The tightened it just to the point to where I couldn't hear it rattle. That put me at 8-9psi. Think thats a bad thing with the TD04 and the 9.0:1 compression?

 

The car seems to like it:-p

Share this post


Link to post
Share on other sites
Think thats a bad thing with the TD04 and the 9.0:1 compression?

 

No, Thats a very good thing!!!...

 

 

 

 

 

 

 

 

 

for a while anyway.....:headbang:

 

Actually, I'd love to know what the limit is. If you find out do let us know....I'd probably wait to turn the boost up until I got a few more miles on the break in (this is a new rebuild right?)

 

btw your wagon is looking pretty pimp these days not quite subaru_styles but atleast your's runs :lol:

 

garner

Share this post


Link to post
Share on other sites
hey now, my car runs and starts everytime.....its just has no power due to teh sheetty turbo:banghead: :lol:

 

Mine doesn't even start!:rolleyes: But it does have a TD04 on it... just waiting for the clutch from Will and she'll be runnin in a matter of a few days:D

Share this post


Link to post
Share on other sites

18hg of vacuum at idle is within specs.

 

The book says there should be 17hg at idle or more.

 

 

Dont feel bad My Vacuum at idle after the rebuild and ported heads is around 10-11hg :)

 

 

When I start it up the idle is aggressive and rough, its gets people's attention, I just yell out "its a *************** having these big race cams" LOL

 

They just look at the car for awhile and smile. HAHA.

 

BTW Running TD04@higher than 7psi I would not recommend with Stock Engine Managment due to the fact that our ECU's are the weakest link with the EA82T's Longevity and Performance.

 

 

BTW Can you guys post some pics of your TD04 installs? I need ideas since I have the turbo and everything, I just need pictures to see how you guys went about it to get a better idea what I need to buy.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×